1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

LOTRO - launcher problems - Siege of Mirkwood

Discussion in 'Games' started by fxjason, Dec 5, 2009.

Thread Status:
Not open for further replies.
Advertisement
  1. fxjason

    fxjason Thread Starter

    Joined:
    Dec 5, 2009
    Messages:
    1
    tried to use Turbine support - they're trying but - no tech support phone calls allowed ... FAIL

    tried every last suggestion on LOTRO support forums ... FAIL

    seems like it would be a simple fix, something I or the Tech Support at LOTRO are overlooking ... heres the prob ...

    Ive been thru about 10 to 15 emails with Turbine Tech Support about this and it seems that no one has the answer to it ... Ive been a member since July of 2008 and I have NEVER had this problem before with updates ...

    please help ... if you can

    Siege of Mirkwood was released DEC 1st ... I had the game already, so no need to download anything ... when I sign into the Launcher it should update itself like usual, right? ... WRONG ... never had a prob like this before , but got hung up on "examining data" ... or something like that ... Needless to say, updates were not working for me that day , no matter what I did . Tried everything I could think of ... then I eventually got it to the point where it kept giving me a "Error loading SelfPatch.dll" ... telling me that SelfPatch.dll was not a valid win32 app.

    After many, what seemed like "canned" responses from Tech Support and many FAILs of their suggestions. Tech finally suggested that I do a full uninstall of everything LOTRO and then a full re-install.

    I did that ...

    Now... it gets to where the main form says "Opening main form" which is where I put in my user name and password to play and then it updates ...

    but now ... it shrinks the main "sign in" form down next to the START BUTTON and it wont allow me to maximize it, most of the time ... at the same time my CPU seems to be working deligently to download something, but i left it on all night and when I woke up ..... NOTHING .... UUUGGGHHHHH!

    Keep in mind ... this is usually where I put my USERNAME & PASSWORD in ... and then it tries to Update ... i dont put either in ... it doesnt even get past the issue of trying to reinstall Direct X 9.0c each time I try to do this

    ... any thoughts on this? [​IMG]

    ...btw ... when I can get the sign in form to come up ... "Game Update Progress" & "Status" are blank ... these usually are doing something when there is an update...

    Then HANG HANG HANG .. looks like it trying to do something, but its not ...

    tried the router ports
    tried uninstall/reinstall .net 1.1 and hotfix
    even uninstalled direct x 9 reinstalled then installed direct x 11
    tried the firewall tricks
    tried a full reinstall of the whole client ...

    what am I missing?

    Jason
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/883007