Magicjack on Win7 Choppy Audio

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

garylwe

Thread Starter
Joined
Dec 30, 2012
Messages
1
On a new fully patched install of Win7 I experienced very choppy audio from my magicjack device. I read forums and tried several suggestions that just did not help to resolve the issue. After working for about an hour with their tech support we came about the fix. I am posting this in hopes to help others that may be experiencing the same issue.

1st we open ports on the firewall:
double click Windows Firewall (make sure it is On so that we can add the ports). Then click Advanced settings in the left column of the Windows Firewall window.
Select Inbound Rules in the left column . >>> Select New Rule in the right column. >>> Then put the dot on the circle for Port, in the New Inbound Rule Wizard and then click Next.
click Protocol and ports, then put the dot on the circle for UDP >>>> then put the dot on the Specific local ports and type 5060 in the box next to it >>> the click the Next button...
select Allow the connection and then click Next. >>> Make sure the boxes for Domain, Private and Public are Checked then click Next. >>> Then type MJ1 as name and click Finish
do the same 1-3 steps, but the port number is 5070 and name it as MJ2

2nd we open udp ports on the router:
Click the Applications & Gaming link near the top of the page.
You should now see a new menu. In this new menu, click Single Port Forwarding or Port Range Forwarding.
then add this replacing 192.168.114 with the ip address of your pc running magicjack:
Application Name : MJ1 External Port:5060 Internal Port :5060 Protocol:UPD To IP Address : 192.168.1.114 and check Enabled box
Application Name : MJ2 External Port:5070 Internal Port :5070 Protocol:UPD To IP Address : 192.168.1.114 and check Enabled box
When you're finished, click Save and apply the Settings near the bottom of the screen to save your changes.

That should do it for you. The audio never sounded better...
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top