Many iexplore processes but Internet Explorer not open

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

namo

Thread Starter
Joined
Jan 17, 2009
Messages
496
I have windows 7 ultimate with Internet explorer 8. I notice in windows task manager Processes that there are serveral iexplore.exe processes running even though Internet explorer is not open. when I end those processor nothing happen and there is no errors. When I open internet explorer browser, I have one page but 2 or 3 iexplore processes and some processor are left after closing the page.

what is the solution?
 

Ent

Josiah
Retired Trusted Advisor
Joined
Apr 11, 2009
Messages
5,467
Restart the computer to remove any leftovers from running IE.
Go to task manager by pressing CTRL + SHIFT + ESC.
If there are any Iexplore processes running, right click on them and click "open file location".
If they are legitimate all Iexplore processes should come from C:\Program Files\Internet Explorer
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top