maxtor external hard drive and vista - worked forever and now it doesn't

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

techpuzzled

Thread Starter
Joined
Apr 19, 2010
Messages
1
I'm running windows vista and I have a maxtor touch mini external hardrive. I've never had any problems with it. But now when I open My Computer the harddrive is nowhere to be seen. I'm all up to date w/ windows updates and when I go into Device Manage it says the device is working properly and is up-to-date w/ it's drivers. So what's the deal? I know my computer is registering the device is there because it makes the 'device inserted' noise and in the safely remove hardware tab the device appears as 'USB Mass Storage Device'. In disk management it shows up as Disk 1 (pretty sure it's referring to that anyway) It says it is unknown and uninitialized, when I try to initialize it an error message pops up that states device is not ready- under properties it says it's working properly and up to date w/ drivers. How can get access to my external harddrive? Please help!!!!!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top