1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Maxtor One Touch won't even start

Discussion in 'Hardware' started by Phreddie, Aug 9, 2007.

Thread Status:
Not open for further replies.
  1. Phreddie

    Phreddie Thread Starter

    Joined:
    Aug 9, 2007
    Messages:
    1
    I bought a Maxtor One Touch Mini III recently which worked fine, until......it hung up while transferring some files. I unplugged it and then the problems started!!

    Firstly, windows explorer does not see it - nor does the Maxtor manager. It whirrs when plugged in, but then the light remains on steady - no flashing.

    I the tried the device manager, where it showed up under "Universal Serial Bus Controllers" as "USB Mass storage Device" with a yellow exclamation mark!

    When I right click on this I get "This device cannot start. (Code 10)" I've tried all the troubleshooting guides, and re-installing the driver (where I just get "cannot find a more recent driver").

    I also tried the drive in two other computers, with the same result - has my brand new drive died?:(

    I'm a beginner at this sort of diagnostic, so bear with me!!
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/607272

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice