Metal Gear Solid Sound Issues

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Stevie C

Thread Starter
Joined
Apr 24, 2003
Messages
75
Hi,
I'm having problems with the sound on Metal Gear Solid 2: Substance for the PC. During codec conversations and during movies, the sound is horribly distorted, if there's no music I can just about barely make out what they're saying but if there is music then no chance, all i get is horrible noises that force me to turn my speakers off. In game sound effects and background music aren't effected, but it's the nature of the game that the dialogues and cut scenes are very important.
I'm using the onboard sound from my MSI K7N2G which is an nforce 2 chipset. I had this problem about 6 months ago and brought the game back, but since I saw it on sale for a tenner and I have newer drivers now I thought I'd give it a go again. I have the most up to date drivers and I've tried patching the game(the patch is only meant to make it compatible with ATI graphics cards anyway, strangely enough I have a radeon 9600XT and the graphics were perfect both before and after the patch)
Anyway, the sound issue seems in some way connected to whatever format is played during movies and cutscenes, because everything else is fine. In the game options I can choose between primary sound driver or nvidia nforce audio, but changing that option doesn't make a difference.
Any ideas?
 
Joined
Aug 1, 2002
Messages
5,531
Not sure about your overall system specs ... how much Ram do you have ?

One thing you might try would be to go Start > Run type DXDIAG to bring up the DirectX Interface - then click the Sound / Audio tab at the top. Try adjusting the Hardware Acceleration slider up / down.
 

Stevie C

Thread Starter
Joined
Apr 24, 2003
Messages
75
Well I have an Athlon 2000+ XP and 512 Mb PC2100 DDR, ATI Radeon 9600XT, its a good system and runs the game fine, just this specific sound problem.
Not at home right now but I'll try that with Direct X diag. Thanks
 
Joined
Sep 14, 2003
Messages
93
I was having the same Problem with America's Army. I was trying to play the sound through the software instead of through my sound card. Check the ingame options. Make sure teh gae isn't set to Dolby 5.1 if you only have 2 crappy CPU speakers too
 

Stevie C

Thread Starter
Joined
Apr 24, 2003
Messages
75
Yep reducing the hardware acceleration down to the second one out of four makes it work fine :)
There's some slowdown at those bits now cos I guess the CPU is calculating a lot of sound stuff instead of the soundcard or something now, but I can live with that I guess.
Thank :)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top