Microphone stopped working. sound card?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

XpLo

Thread Starter
Joined
Feb 3, 2013
Messages
1
Hi.
OS: Windows 7 64
Sound Card: Sound Blaster Audigy

I was playing a game on ventrilo and got up from my seat and tripped over my headset cord.
I have a Sennheiser PC350. I didn't pull it out of the ports. So I checked and I could still hear out of everything.
But nobody could hear me. So I unplugged my headset and tried again. Microphone wasn't working.
So I tried a different headset. Brand new gaming headset out of the package. Sound worked. Microphone didn't.

Is it possible I broke my soundcard? I cant see how.
Is there anything else I can check?
 

Oddba11

Jim
Joined
May 12, 2011
Messages
8,177
Assuming you are connected directly to the sound card, yes, it could be damaged.

Enable the onboard audio chipset and test using front or rear panel ports. That will at least determine if you have a faulty sound card or headset.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top