Microsoft Edge not loading

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

IvahOB

Thread Starter
Joined
Jun 11, 2017
Messages
3
Edge loads to a blank screen and after 30 seconds or so disappears.
I've restored back to a restore point before the problem started and that doesn't work either.
I've searched for fixes and the most recommended is deleting the specific packages directory then reloading Edge using Powershell. This doesn't work.
If I go into Safe Mode without Networking I get the message "Microsoft Edge can't be opened using the built-in Administrator Client".
Any ideas please?
 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,184
Microsoft Edge can't be opened using the built-in Administrator Client".
That is correct it cannot be it requires a user account with admin rights not the system admin account

Which account are you using please

You have not disabled User Account Control have you
If it is Edge will not run
 
Last edited:
Joined
Jun 11, 2017
Messages
3
I am having the same problem, I am the PC admin account with all the rights/access. A few days ago when I clicked on Microsoft Edge which was set as my default it opens, just shows a white page for the contents, if you type in an internet address before it freezes it doesn't load anything and then just shut down. My PC is fully up to date, it just stopped working.
 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,184
If you are asking for us to assist YOU
After selecting a forum category, press the orange “Post New Thread” button at either the top or bottom of the list of existing questions. When writing your question, please be as descriptive as possible. Please be sure to include your operating system (Windows 7, Windows 10, etc) as well as the exact text of any error message that you might be seeing.
we will be more than pleased to help
follow the procedure as outlined in our welcome guide from which I have quoted above
 

IvahOB

Thread Starter
Joined
Jun 11, 2017
Messages
3
If you are asking for us to assist YOU


we will be more than pleased to help
follow the procedure as outlined in our welcome guide from which I have quoted above
I thought I was reasonably descriptive apart from not saying Windows 10 Home.
As the other responder has implied there are no error messages just Edge disappearing.
It has taken me a while to answer your prompt reply, for which I thank you, because I spent much of the afternoon with Microsoft support controlling my machine. They tried a few things including creating a new user and couldn't solve it, they concluded it was a update corruption issue. Their solution was a new install preserving all files which obviously took a while. At the end of that Edge wouldn't even load, when I went the menu route rather than shortcut it said it was looking for the directory with 8wekyb etc. in the name, it wasn't there. I then ran the Powershell reinstall script that a lot of web searches lead to and that restored Edge to its previous crashing mode. I got back to Microsoft Support and they gave up and booked a Level 2 call for tomorrow.
I then started to try and use my machine and found it was worse than previously with Chrome freezing on a regular basis (by the way all through this Internet Explorer has continued to work). I decided not to wait for Monday's call as I have things to do so restored to a system image of about a week ago (I was going to use the gentler option of a restore point but their reinstall had of course removed all restore points) and Edge now works and I am replying to this in Chrome. What I haven't risked yet is doing a forced Windows Update to see if it spoils things again.
I have to say my normal browser is Chrome and I only use Edge when I have Chrome issues which I think are usually associated with Trusteer Rapport which I have to run or my bank would not cover any losses. I use Trend Maximum Security for anti-virus if you think that could be relevant.
 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,184
You have misunderstood my post was in reply to Adam41UK
After selecting a forum category, press the orange “Post New Thread” button
I apologise for not making it clear that the remark was addressed to him

Please wait while I read your last
 

Macboatmaster

Trusted Advisor
Spam Fighter
Joined
Jan 14, 2010
Messages
24,184
1. I am surprised that your bank insist that they will not cover losses unless you have Trusteer installed. I have NEVER encountered this. I have seen it pushed with strong recommends but never seen the ultimatum.
It is a most disruptive process and very unsuitable for 10. I have yet to see it work well, without causing problems on any 7, 8 or 10
2. Trend Micro although it may be good as an AV is not suitable for 10

3. I have little doubt that your problems are caused by these
They like many other 3rd party security programs work OK on 10 until a Windows update when many aspects go haywire
Defender the included AV is the only one that can guarantee 100% compatibility - 100% of the time

4. If you wish I can give you many examples of the problems caused on 10
My strong recommendation is to un install Trusteer
Uninstall Trend Micro
Check Defender is running and updated
Carry out a system file check
Then report the results and if all OK reconfigure the updates
 

IvahOB

Thread Starter
Joined
Jun 11, 2017
Messages
3
Thanks for all that. I have got the impression things change as 10, Trend, Rapport and Chrome update; sometimes they are happy together then become unstable for a few days. I'll look again at bank T&Cs and see if it is just strongly recommend or even ask if 10 with Defender is considered OK. I will mention the configuration to Microsoft tomorrow though it was obvious enough for them to spot while they were in control. I'll also try a configuration without Trend and Rapport. I've always liked the idea of a strong third party product, after all there is no point in writing something nasty that the basic system will stop and there is always the chance that the third party will. Things have changed with 10 in that Microsoft take security more seriously and perhaps I haven't moved with the times (you tend not to at 70!).
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top