Microsoft Edge Not Working

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Adam41uk

Thread Starter
Joined
Jun 11, 2017
Messages
3
I have been using windows 10 now for a while with no issues. I have been using Microsoft edge for a while but now it isn't working. After opening edge it goes to a blank content screen but all the tool bars are there. If I am quick I can open menus or type in an address but it doesn't go anywhere, eventually freezes and then closes. I have tried some other peoples suggestions of creating another user account (same thing happens), I have tried to restore the system by going back to a restore point to no effect, I have tried to access it through a voice search on Cortana with no luck, I have tried to use the app trouble shooter and no luck. UAC is on, never had an issue with it before. I am on the admin account, PC is up to date and on automatic updates. all user on the PC have the same problem.
 

Adam41uk

Thread Starter
Joined
Jun 11, 2017
Messages
3
All things like flash player etc are disabled on it, I have heard mention of a microsoft update that maybe the problem.
 
Joined
Jun 14, 2017
Messages
4
Don't reinstall - you'll just end up in the same place. I actually saw this on my own machine, and something is messing with security. To put it back to the way it should be (and have it work), do the following, in this order:1. Open the registry editor to the following key - HKEY_CLASSES_ROOT\AppID\{ADA41B3C-C6FD-4A08-8CC1-D6EFDE67BE7D}2. Change the permissions on the key itself by right-clicking on the {ADA41B3C-C6FD-4A08-8CC1-D6EFDE67BE7D} key, and selecting "permissions" 3. This will open up a permissions dialog box. Click the "Advanced" button:4. The key is owned by trustedinstaller - this needs to change before we continue, so click the "Change" link:5. Assuming the account you're using is part of the Administrators group, just type in "Administrators" in the box and click the "OK" button:6. Click the "Apply" button, then click the "OK" buttons until the permissions dialog window closes:7. You will need to right-click the registry key again (from step 2) and select "Permissions" again from the list:8. With "Administrators" highlighted, click to place a check into the "Full Control"/"Allow" box:9. Click the "Apply" button, then click "OK" again until the permissions dialog window closes:10. Now, go to the start screen and type "dcomcnfg" - this should show up in the search, and you will need to click on it to open the Component Services window.11. Once the Component Services window is open, browse to Console Root > Component Services > Computers > My Computer > DCOM Config, and find "WPN Srumon Server" from the icon list - right-click on this icon and select "Properties":12. Click the "Security" tab, and click the "Edit" button in the "Launch and Activation Permissions" section:13. Click the "Add" button:14. Type in the user name from your error dialog *exactly* as it appears in the error dialog from the event viewer (for example, I'm using "Administrator" here, but if your error message says "<computer name>\Donald", then the user name you would use would be "Donald") - again, I'm using the user "Administrator" as an example here; replace with your user name from your machine as necessary, and click the "OK" button:


Ethan Stark
cloudappsportal
 
Last edited:

texasbullet

Ramon
Joined
Jun 11, 2014
Messages
2,777
Try using Internet explorer. On the search button type internet explorer and click enter or install google chrome or whatever web browser you like.
 
Joined
Jan 31, 2013
Messages
31
I have this issue. As far as I can see it is related to the recent W10 update.
I only use Edge/IE for the another news site so it is no real problem, Opera being my default browser. I am using IE againfor the news items.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top