1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Microsoft Loopback Adapter causing a firewall-like effect

Discussion in 'Networking' started by BLooDCalibuR, Mar 12, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. BLooDCalibuR

    BLooDCalibuR Thread Starter

    Joined:
    Mar 12, 2010
    Messages:
    1
    Whenever I try to use/enable my Microsoft Loopback Adapter it causes a "firewall-like" effect, meaning no one can connect to my ventrilo server (which is run on my computer) except for myself as well as other things that normally would require port forwarding to be able to share with such as hosting on games. When I have it off/disabled, everyone can join, such as join my hosted games.

    My biggest confusion is that this was working fine just two days ago. I'm using a Linksys router (model BEFSR41) and haven't had problems in many many years concerning port forwarding or hosting on games or hosting a server (ventrilo, etc.). My port forwarding seems to be correct since when I have the Microsoft Loopback Adapter disabled everything works fine. I'm also obviously using Static IP settings on my Local Area Network (aka the main one thats used to connect to the internet) to allow my port forwarding to work properly. Microsoft Loopback Adapter was working fine before, but ever since I changed my external IP Address (you know, the typical way of changing your MAC address on your router settings and then doing a power cycle to get a new IP Address) and updated the IP Address settings in the Microsoft Loopback Adapter, it would cause a firewall like effect and now allow connections to my computer. The internet/browsers work fine of course and I'm the only one who can connect to my ventrilo server or my own hosted games.

    The reason why I NEED to use the Microsoft Loopback Adapter is because it's required by one of the hosting bots I use to host my games on Warcraft 3 so that it stops me from being booted off my own host at the beginning of the game. Like I said, everything works fine ever since I changed my IP Address.

    So far I've tried the following things:

    Flushed the DNS
    Repaired
    Released
    Erased all the IP settings for both Local Area Network and Microsoft Loopback Adapter
    Uninstalled Microsoft Loopback Adapter and Reinstalled it
    Power Cycled many times in between those

    If anyone knows what could be wrong, or if I must've not tried something, I'd appreciate a well detailed response, thank you.

    I'm using a Windows XP Pro operating system.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/909575