Microsoft .NET Framework 4 and terraria problem

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Da_money124

Thread Starter
Joined
Jul 30, 2005
Messages
34
I'm trying to play terraria, but it has issues with XNA 4 and Microsoft .NET Framework 4 . So the steam support page ->https://support.steampowered.com/kb_article.php?ref=3952-ROGX-0025 told me to Uninstall Net 4 and Xna 4.
I also installed all my other Net frameworks 3, 3.5, ect. Now when I try to install Framework 4 is says it Failed to install because of a fatal error.
I can't try to install XNA 4 because the support page says to install the frame work first.
So I'm kinda stuck trying to fix this before I can begin to fix Terraria.
Please help me!

Is it ok if I post the Installation Log here?
 

Da_money124

Thread Starter
Joined
Jul 30, 2005
Messages
34
Heres the log file; short version, If this still does not help I could post the REALLY long version

OS Version = 6.1.7600, Platform 2
OS Description = Windows 7 - x64 Home Premium Edition
CommandLine = C:\f0e8f239409399ff89\\Setup.exe /x86 /x64 /ia64 /web
TimeZone = Eastern Standard Time
Initial LCID = 1033
Using Simultaneous Download and Install mechanism
Operation: Installing
Package Name = Microsoft .NET Framework 4 Setup
Package Version = 4.0.30319
User Experience Data Collection Policy: Disabled
Number of applicable items: 11
Exe (C:\f0e8f239409399ff89\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
ServiceControl operation succeeded!
ServiceControl operation succeeded!
Exe (C:\Users\Ryan\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null).
Exe (C:\f0e8f239409399ff89\SetupUtility.exe) succeeded.
Exe Log File: dd_SetupUtility.txt
MSI (C:\Users\Ryan\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20111212_012909529-MSI_netfx_Core_x64.msi.txt
Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:01:24).
 

Da_money124

Thread Starter
Joined
Jul 30, 2005
Messages
34
I'm not sure why nobody will even suggest something I could do to fix this. And now I have a bunch of Steam games from the Christmas sale that don't work either :( So please some one help me!
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top