mini computer dead

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

roncology

Thread Starter
Joined
Dec 12, 2018
Messages
14
just bought a mini computer t-7 running windows 10. after doing all the necessary new setups when 1st turned on , it asked to update Microsoft edge. when i clicked on it , the computer went blank . tried hitting reset button, tried holding in power button , nothing happens. only little blue indicator lights come on. tried reaching out to company in china, (NewFrog) they have no clue,
any advice appreciated thanks Ron
 
Joined
Sep 21, 2007
Messages
13,663
You clicked something bad, never heard of an Edge only update. Usually there are cumulative bi-monthly/monthly updates which arre one download which holds everything.

Go get the MS Media Creation Tool . Use it to generate a DVD/USB stick. Boot with it and re-install Windows.
 

roncology

Thread Starter
Joined
Dec 12, 2018
Messages
14
thank you so much for reply. i already created a windows 10 stick when i converted my Lenovo laptop from windows 7 to 10. is it okay to use that? probably tap f10? thanks again Ron.
 
Joined
Sep 21, 2007
Messages
13,663
If you have already created the USB stick, then use it.
Different laptops assign different keys to choose boot order of devices.
 

roncology

Thread Starter
Joined
Dec 12, 2018
Messages
14
thank you for all the advise, but unfortunatly, still dead, wont turn on, only little blue light comes on, tried reset button holding power button, still nothing . will try reaching out to New frog again see if i can return it its only 1 month old.
 

roncology

Thread Starter
Joined
Dec 12, 2018
Messages
14
still have issues with my T-7 mini computer still dead only blue indicator light comes on , any ideas? thanks.
 
Joined
Sep 21, 2007
Messages
13,663
Take out the CMOS battery, wait 15 mins, put it back in. See if you can get into the bios to set boot order .
 

roncology

Thread Starter
Joined
Dec 12, 2018
Messages
14
took it apart could not find a battery. only a big heat sink and ports for the periferals will try to post a pix.
 

texasbullet

Ramon
Joined
Jun 11, 2014
Messages
2,912
Might be the graphics card that is defective. If still under warranty send it for repair or exchange.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top