minimizing notepad

Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

brooke

Thread Starter
Joined
Feb 2, 2000
Messages
69
I just installed a new Win98SE for a user and when she opens some files associated with notepad, it opens the file then automatically minimizes the window. It's rather annoying. I can't find a solution on Microsoft's site, and I can't find anything in the shortcut properties or in the file associations that looks funny.
 

TonyKlein

Malware Specialist
Joined
Aug 26, 2001
Messages
10,392
Hi Brooke,

I found the following at <A HREF="http://members.aol.com/axcel216/">AXCEL216's MAX Speeed WinDOwS Tricks Secrets Bugs Fixes</A> :

To get Notepad to maximize upon startup, create a batch file with this line:

@START.EXE /MAX %windir%\NOTEPAD.EXE

This will start a DOS box and then Notepad. Call the batch NOTEMAX.BAT or whatever you like.
Actually you should right-click on the BATch file's shorcut (PIF = MS-DOS Program Information File), place a check mark in the "Close on exit" box under the Programs tab, and make sure you run it Minimized. :)
Last step: associate your .INI and .TXT files with NOTEMAX.BAT.
You can do this by editing the Registry. Run Regedit and go to these keys:

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\inifile\shell\open\command
@="%windir%\\NOTEPAD.EXE /n \"%1"

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\txtfile\shell\open\command
@="\"%windir%\\NOTEPAD.EXE\" \"%1\""

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Applications\Notepad.exe\shell\edit\command
@="%windir%\\NOTEPAD.EXE %1"

Replace all NOTEPAD.EXE instances under the "(Default)" String Values with NOTEMAX.BAT, and make sure to type in the full path to your BAT file.
Close Regedit when done."

Good luck,
 

brooke

Thread Starter
Joined
Feb 2, 2000
Messages
69
This didn't work. It now makes files in opened in notepad uneditable. I will try something else. I think it has to do with how the file associations are set up.
 

TonyKlein

Malware Specialist
Joined
Aug 26, 2001
Messages
10,392
You may be right Brooke,

Maybe add the appropriate switches to the path, but I could'nt really tell you much more.

Maybe there's a way through editing HKEY_CLASSES_ROOT\txtfile\shell\open\command

By the way, do take a look at that registry key. Does it say C:\WINDOWS\NOTEPAD.EXE %1 ?

This sounds like a case for Mosaic1! :D

Good luck,
 
Joined
Feb 16, 2001
Messages
841
Hi brooke. Do you have a shortcut set up for Notepad.exe? If you do try right clicking on it>Properties. Beside the "Run" line does it say Minimised? If so, change it to Normal or Maximised window. If you don't have a shortcut to it, just create one and then you can check out what is shown in the "Run" line.
Good luck :) sharon
 

TonyKlein

Malware Specialist
Joined
Aug 26, 2001
Messages
10,392
Well, on further thought, the problem seems to be, that it first starts up normally and then minimizes, and that's different from starting up minimized, at least if I understand correctly what Brooke said.
Let's wait for her/his reaction first.

Greetz.
 
Joined
Feb 16, 2001
Messages
841
Tony, I just reread through brooke's post and I think you might be right. I guess we just wait and see.
 

TonyKlein

Malware Specialist
Joined
Aug 26, 2001
Messages
10,392
In all fairness, I talked this over briefly with Mosaic1, and she pointed that out to me.
I often react to a post without reading it carefully enough as well...:rolleyes:

Greetz,
 

brooke

Thread Starter
Joined
Feb 2, 2000
Messages
69
You are correct...it starts out normally (sort of blinks on the monitor for about 3 seconds) then minimizes.

Let me explain the problem more in detail:
We receive electronic files from the department of Education. Everytime a new one is received, the program automatically assigns the next numbered extension to the file (eg text.123, text.124, etc.) Usually, when you double click on the file for the first time, you pick Notepad from the list of Applications, and it opens...no problem. Well, with this new machine, when you pick Notepad for the first time, it does the funky minimizing thing. After you open it the first time, it opens regularly after that...AFTER the file association has been created...which leads me to believe that it's the file association that's leading to the problem, not Notepad itself...but I could be wrong. I dont' want to have to reinstall Windows for this small problem, but do you think reinstalling the Accessories would help?
 
Joined
Aug 17, 2001
Messages
7,486
First. If you are receiving text files and using numbers as extensions, then associating each number with notepad, you are bloating your registry. Each association is being entered into the registry. I would do this: upon receipt of text.123
I would rename that file as 123.txt
Notepad should open that file.
 

brooke

Thread Starter
Joined
Feb 2, 2000
Messages
69
Can't do that, Mosaic. Can't rename them. With the way the Dept of Ed sends us the files, it is their system that assigns the next successive # to the file. If we renamed the files, the next time we received files from them, their software wouldn't know what # to put on as the extension and/or it would overwrite an existing file, which is BAD BAD BAD!!!
I'll keep looking for a solution. We have never had a problem until this new PC.
 
Joined
Aug 17, 2001
Messages
7,486
I would try this then because your registry is being loaded with file extensions. I would rename all but the last. When the next comes in, rename the last. And I would go into the registry to
HKEY_CLASSES_ROOT and remove all those 123 124 etc file extensions. That is a ridiculous way to name files. Something they should reconsider if possible.
( The way it's being done now takes away your ability to restore a previous registry and be able to recieve these files correctly too because the last would not appear there. You would have to reenter the last one.)
That makes for a lot of work, but your registry will thank you for it.

I don't know what it is about these files and your new installation of Notepad. If this is the only machine doing this?

Try removing Notepad and reinstalling. Before you reinstall go into the registry and remove the Notepad key here: (export it first for safekeeping incase of a problem.) To export, highlight the key and then go to the toolbar>registry>export registry file
HKEY_USERS\.DEFAULT\Software\Microsoft\Notepad
then right Click on Notepad and delete.
 
Status
This thread has been Locked and is not open to further replies. The original thread starter may use the Report button to request it be reopened but anyone else with a similar issue should start a New Thread. Watch our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top