Minus Key Does Not Work in Excel 2010

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

icashootnstar

Thread Starter
Joined
Sep 23, 2007
Messages
13
The minus key on my ASUS N75SF does not work as a leading "-" in a cell in Excle 2010. It works perfectly fine when entered after other numbers in the cell.
ASUS is saying that it's a hardware problem and that I need to return the computer for repair! This doesn't make much sense to me if it works under certain conditions.
I suspect that it has something to do with an Excel setting.
Any ideas?

Thanks,
Shannon
 

etaf

Wayne
Moderator
Joined
Oct 2, 2003
Messages
65,487
what happens when you type - in excel cell

you can change the format on how a negative number is displayed
http://office.microsoft.com/en-gb/e...gative-numbers-are-displayed-HP001216500.aspx

if thats not the case try using the onscreen keyboard > start>programs>accessories>ease of access>on-screen keyboard

can you post a sample spreadsheet and also post a screen shot of what you see

To post a screen shot of the active window.
1) hold the Alt key and press the PrtScn key. Open the Windows PAINT application (Start> All Programs> Accessories> Paint) and Paste the screen shot. You can then use PAINT to trim to suit, and save it as a JPG format file.
OR
2) if you are using Vista/Windows 7 you can use the "snipping tool" which is found in Start> All programs> Accessories> Snipping Tool

To upload the screen shot to the forum, open the full reply window ("Go Advanced" button) and use the Manage Attachments button to upload it here.
Full details are available here http://library.techguy.org/wiki/TSG_Posting_a_Screenshot
 

icashootnstar

Thread Starter
Joined
Sep 23, 2007
Messages
13
Thank you for your response.

I’ve checked the Excel negative number formatting and it is set to display the “-“ for negative numbers, so that’s not it.
The key giving me trouble is part of the 10-key array built into my keyboard (see pic attached). However, I ran the on-screen keyboard and the minus sign there worked fine, though it is a qwerty display and the key doesn’t correspond to the one in question.

I’ve uploaded a sample file and the snapshot, both showing keystrokes and the results. I hope this makes it easier to understand.

The key works just fine as long as it is not the leading “-“ in an Excel cell. Very perplexing.
I did have one other suggestion to flash the BIOS. But I would rather have a better idea of what the problem is before I go around shooting in the dark and possibly causing more headaches.

Cheers!
Shannon
 

Attachments

etaf

Wayne
Moderator
Joined
Oct 2, 2003
Messages
65,487
strange issue - not sure how the bios will help - bit you need to note and issues when updating the bios will make the PC unusable - so not to be entered into lightly

i have added the - see if you can see it
 

Attachments

icashootnstar

Thread Starter
Joined
Sep 23, 2007
Messages
13
Yup. So it's not the spreadsheet file itself. Still could be a setting in Excel. But nobody has voiced any possibilities there that I haven't checked.

It looks like it's flash the bios or return the computer. So frustrating when there's a strong suspicion that it really is something else!

Thank you for your help and please let me know if you get any lightening strike ideas. I'll hold off for a little while.

Mahalo,
Shannon
 

icashootnstar

Thread Starter
Joined
Sep 23, 2007
Messages
13
I hadn't used either of those. But it did give me an idea. I tried opening a Google Drive spreadsheet converted to Google Sheet and the minus worked just fine there too. So it is certainly something to do with Excel!
 

icashootnstar

Thread Starter
Joined
Sep 23, 2007
Messages
13
Interesting reading, unfortunately…

I’m not running any RDP and, unfortunately, I don’t have a numlock key, so I can’t test that solution.

I’m not running linux, so I don’t have the registry entry mentioned. Also, since it’s the 10-key part of the keyboard that is causing the problem, I doubt this would work for me.

Ditto the onscreen keyboard, though we did try this and the qwerty “-“ works fine (as it does on my hardware keyboard.)

I have no custom keyboard shortcuts assigned and Lotus Compatibility is non enabled.

The”-“ is not in my Custom Dictionary.

I did go ahead and do a “Repair” of MS Office 2010.

As I mentioned the 10-key “-“ works fine in all other software except Excel. And even then, the problem only occurs when it is the first character typed into a cell. Very frustrating…
 

icashootnstar

Thread Starter
Joined
Sep 23, 2007
Messages
13
Wonder of wonders! The BIOS flash did the trick! ASUS has a Winflash utility that made it pretty painless. But I still approached it with some trepidation.
Thank you for all of your help. As usual, it was a good learning experience!

Shannon
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top