1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Solved missing HDD

Discussion in 'Hardware' started by Sheed22, Jul 14, 2019.

Thread Status:
Not open for further replies.
Advertisement
  1. Sheed22

    Sheed22 Thread Starter

    Joined:
    Jul 14, 2019
    Messages:
    6
    my hard drive is missing from device manager and file explorer after i pulled the SATA plug from it please someone help me figure this out i tried rebooting but its still missing i hope its not dead
     
  2. Jakbrud

    Jakbrud

    Joined:
    May 18, 2004
    Messages:
    326
    Is it showing up in the BIOS?
     
  3. Sheed22

    Sheed22 Thread Starter

    Joined:
    Jul 14, 2019
    Messages:
    6
    how do i find that out please let me know
     
  4. Sheed22

    Sheed22 Thread Starter

    Joined:
    Jul 14, 2019
    Messages:
    6
    i just unplugged it and then i plugged it back in i wonder if its doing this because i touched the bottom of it im sure i plugged it in properly i dont know what else to do
     
  5. Sheed22

    Sheed22 Thread Starter

    Joined:
    Jul 14, 2019
    Messages:
    6
    yes i fixed it it turns outs that the cable connecting to the MB wasn't actually connected right so i plugged it back in and it was working
     
  6. managed

    managed Trusted Advisor Spam Fighter

    Joined:
    May 24, 2003
    Messages:
    12,222
    First Name:
    Allan
    How many hard drives are in that computer ?
     
  7. Sheed22

    Sheed22 Thread Starter

    Joined:
    Jul 14, 2019
    Messages:
    6
    it has 1 SSD and 1 HDD i already solved the problem it turns out that the ribbon cable connecting to the MB wasn't connected it was out so i connected it and now its detected
     
  8. managed

    managed Trusted Advisor Spam Fighter

    Joined:
    May 24, 2003
    Messages:
    12,222
    First Name:
    Allan
    I missed your previous post #5. Glad you fixed it.
     
  9. Sheed22

    Sheed22 Thread Starter

    Joined:
    Jul 14, 2019
    Messages:
    6
    ya i didn't even realized it until i looked at the ribbon cable and saw that one of them wasn't connected, the one connecting to the MB was disconnected but the one on for the SATA port in the HDD bay was fine, so it would never detect it since it wasn't connected to MB silly me.....
     
  10. managed

    managed Trusted Advisor Spam Fighter

    Joined:
    May 24, 2003
    Messages:
    12,222
    First Name:
    Allan
    Some Sata cables have a latch on the connectors that has to be pressed in before they will come out of the socket, motherboards often come with a couple of these cables.
     
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1229995

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice