1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

missing letters mystery

Discussion in 'Hardware' started by dondondon, Feb 5, 2018.

Advertisement
  1. dondondon

    dondondon Thread Starter

    Joined:
    Feb 5, 2018
    Messages:
    3
    Tech Support Guy System Info Utility version 1.0.0.4
    OS Version: Microsoft Windows 7 Ultimate, Service Pack 1, 64 bit
    Processor: Intel(R) Core(TM) i5-2320 CPU @ 3.00GHz, Intel64 Family 6 Model 42 Stepping 7
    Processor Count: 4
    RAM: 8086 Mb
    Graphics Card: Intel(R) HD Graphics, -1988 Mb
    Hard Drives: C: 214 GB (119 GB Free); E: 240 GB (159 GB Free); K: 1002 GB (895 GB Free); X: 214 GB (121 GB Free); Y: 240 GB (148 GB Free);
    Motherboard: LENOVO, MAHOBAY
    Antivirus: Malwarebytes, Enabled and Updated

    Several months ago, pressing the letter h on the keyboard stopped registering on the monitor.
    I bought another keyboard but the letter continued to register. However, during this period, the letter y stopped working but the h returned. Using autohotkey I was able to live with this BUT now the letter a has
    also stopped working. It may sound a bit comical but isn't funny. Two different software programs indicate that
    the letters a and h have the correct scancodes attached to them. And only these two letters don't work on two different keyboards!

    Thanks for any help you can suggest...
     
  2. Sponsor

  3. SpywareDr

    SpywareDr

    Joined:
    Mar 30, 2014
    Messages:
    1,162
    Do all of the keyboard keys work correctly after booting up into Safe mode?
     
  4. dondondon

    dondondon Thread Starter

    Joined:
    Feb 5, 2018
    Messages:
    3
    Thanks for responding, metallica5456!

    Yes, the letters [y and a] do work normally in safe mode.
     
  5. dondondon

    dondondon Thread Starter

    Joined:
    Feb 5, 2018
    Messages:
    3
    Brethren, the problem was caused by use of the ampersand key in creating macros with the autohotkey program. Compiling ahk files with such a macro e.g. t & v::run would wipe out the normal function of the first key, in this example, the letter t. Thank you all.
     
    Last edited by a moderator: Feb 15, 2018 at 8:40 AM
  6. Cookiegal

    Cookiegal Administrator Malware Specialist Coordinator

    Joined:
    Aug 27, 2003
    Messages:
    108,873
    metallica5456 didn't respond, it was SpywareDr.
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...

Short URL to this thread: https://techguy.org/1204344