Missing The Safely Remove Hardware Icon...

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

jnulu

Thread Starter
Joined
May 18, 2005
Messages
73
I am aware that this subject has been discussed threadbare on this forum as well as many others
with no one solution that completely solves this problem for every one.
A number of suggestions, work arounds have been put up by a lot of people.
Some seem to work for some, and some do not.
I seem to have stumbled on a solution but this, unfortunately is not permanent.
Let me explain:

I am running Windows XP Professional with SP2.
Windows Firewall is installed, as is, the excellent, Nod32 Antivirus.

Quite sometime ago, I lost the Safely Remove Hardware icon and also
the Volume Control icon from the Notification area of the System Tray.
I do not recollect why or how this came about.

Scouring several forums over a period of time in search for an answer, I realised
that the SRH icon can be made to show up in the System Tray by:
Click on Start/Control Panel/Sounds and Audio Devices and placing a check mark in the
'Place volume icon on the task bar' check box.
This immeditely places the two icons referred to above in the System Tray.
I also ensure that the icons are set to 'Always show' by right clicking on the system tray
and selecting 'Customize Notifications...' and then clicking on Customize after the 'Hide
when inactive' check box is ticked.
You can also see from the attached first snapshot that the Customize Notification panel exhibits
only ‘Current Items’ (There are no ‘Past Items’ showing now)
Also seen in the snapshot are the Volume and SRH icons in the System Tray.

So far, so good!
I restart the computer and the same two icons are now found missing.
The others that were there in the beginning, are still there (Nod32 and Find and Run
Robot). Here's the second snapshot to illustrate this:
This snap shot also shows the two icons that are now absent in the 'Current Items' to
and appear in the 'Past Items'!

As mentioned in my opening remarks, I know of some work arounds to remove hardware
like an USB device for example, without using the SRH icon in the System Tray.
As such, I am now confining my request to the knowledgeable folks here, for some
registry hack (if there's one) or some other permananet solution that ensures the icons,
remain in the 'Current Items' of the Customization Panel.
In which event, the two icons will then show up in the System Tray permanently.
Or if the icons are there in the System Tray permanently, then automatically they
will be showing up in the 'Current Items'.
Thanks!

Jay
 

Attachments

Joined
Apr 7, 2007
Messages
4,910
Start > Run > Regedit > Navigate To

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TrayNotify

On The Right Pane Delete IconStreams And PastIconsStream

Now .. Open Task Manager > Go To Process Tab > Right Click On Explorer.exe And Click End Process ..

In TaskManager Go To File > New Task(Run..) > explorer.exe > And Hit Enter

Reboot And Check !
 

jnulu

Thread Starter
Joined
May 18, 2005
Messages
73
Hi devil_himself!

Am I to delete the Icon Streams and the Past Icon Streams or just the binary data they hold in it? Please clarify.
In one of the forums, I was asked to delete ONLY the data the Streams held and then follow the rest of
the steps you have outlined.
I followed those instructions, but wasn't successful in putting the SRH icon back into the System Tray.
Thanks for your help!
 

jnulu

Thread Starter
Joined
May 18, 2005
Messages
73
Hi Bingo24!

I have tried out all the work arounds suggested in the URL you have so kindly given me.
They help, but what I am looking for is a permanent solution that keeps the SRH Icon in the System Tray, always.
The only thing that I have not tried out is running the systray.exe as it looks like it will be
cleaning up the entire registry, a solution I will try, if all else fails.
Meanwhile, thanks for your help.
Regards
 
Joined
Apr 7, 2007
Messages
4,910
Delete "IconStreams And PastIconsStream" And Restart The Shell Or It Will Not Work

Start > Run > WMIC PROCESS WHERE Name="explorer.exe" CALL Terminate
 

jnulu

Thread Starter
Joined
May 18, 2005
Messages
73
Thanks!
As instructed, Icon Streams and Past Icon Streams were deleted completely and the Registry was closed.
Next explorer.exe process was ended in the Task Manager and a new explorer.exe was started via the
TaskManager, Go To File > New Task(Run..) > explorer.exe > and then hitting Enter.
The PC was rebooted. The System Tray did not have the SRH and Volume icons.
On a hunch , checked the registry and found both the Icon Streams and Past Icon Streams back
along with the binary data! :mad:

At this stage I am a little confused.
When am I supposed to run the following?
Start > Run > WMIC PROCESS WHERE Name="explorer.exe" CALL Terminate
Or, is this and the previous instruction, that is:
Now .. Open Task Manager > Go To Process Tab > Right Click On Explorer.exe And Click End Process ..
In TaskManager Go To File > New Task(Run..) > explorer.exe > and
hitting Enter, one and the same?

Grateful for further instructions.
 
Joined
Apr 7, 2007
Messages
4,910
When am I supposed to run the following?
Start > Run > WMIC PROCESS WHERE Name="explorer.exe" CALL Terminate
Or, is this and the previous instruction, that is:
Now .. Open Task Manager > Go To Process Tab > Right Click On Explorer.exe And Click End Process ..
In TaskManager Go To File > New Task(Run..) > explorer.exe > and
hitting Enter, one and the same?
These Two Instructions Are Same ...

Try This

Go To Start > Run > regsvr32 hotplug.dll
 
Joined
Jun 9, 2005
Messages
115
i have the same problem.But only the Safely remove disk is missing.The Safely remove disk is in the past item.How can i bring it back to the current items?
 
Joined
Jun 9, 2005
Messages
115
oh from searching the net i found this and it works...it restored my "SRH"...try this one...i plug in first the usb device that cause all the troubles and did this:

Safely remove hardware icon found
by pas_uob - 9/3/07 4:47 AM
In reply to: Safely remove hardware icon missing by Gryta
I had the same problem with an external hard drive. The "Safely remove hardware icon" always used to show, then suddenly went missing. I went into the external hard drive's properties (through My computer). Under the "Hardware" tab, I selected the external hard drive and clicked "Properties". Under the "Policies" tab, there are two options: "Optimize for quick removal" or "Optimize for performance". The former suppresses the "Safely remove hardware icon" so you don't have to use it. Selecting the 2nd option requires a reboot but, once completed, the "Safely remove hardware icon" reappears.

Not at all clear why/how the first option abruptly became selected - but such are the joys of working with Windows.
 
Joined
Apr 7, 2007
Messages
4,910
This Issue Is Not Related To "Safely Remove Hardware Icon" Showing In "Past Items".
Everything That Is Present In" Notification Area" At A Particular Time Will Appear In "Current Items" And Everything Not In "Notification Area" At Present But Was Sometime Ago Will Appear In "Past Items"

When You Plug In Your "Pendrive" In USB .. Then Also Is The "Safely Remove Icon" Showing in "Past Icons" ?
 

jnulu

Thread Starter
Joined
May 18, 2005
Messages
73
When You Plug In Your "Pendrive" In USB .. Then Also Is The "Safely Remove Icon" Showing in "Past Icons" ?[/QUOTE]

The answer to the above question is a YES.
The only way the Past Icons become Current, is when I go to:
Start/Control Panel/Sounds and Audio Devices/Volume Tab and
there, place a check mark in the check box of 'Place Volume Icon' In The Task Bar.
The SRH and Volume icons show up immediately in the Task Bar and as said above,
the Past Icons
disappear from the Past and show up in the Current Icons.

I have also tried your other suggestion:
Go To Start > Run > regsvr32 hotplug.dll
without any success. (I had tried a similar suggestion
previously on the advice of another member from another forum, but it did not solve my problem).
 

jnulu

Thread Starter
Joined
May 18, 2005
Messages
73
Thanks deaddrop!
I was suggested this solution by a member from another forum
and unfortunately did not help :-(
Regards
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top