1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Monitor "Freeze"

Discussion in 'Hardware' started by RaptorJesusDesu, Aug 23, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. RaptorJesusDesu

    RaptorJesusDesu Thread Starter

    Joined:
    Aug 23, 2007
    Messages:
    7
    Hey guys,

    I'm posting here because I can't seem to find the problem anywhere else. I have a standard Dell 17' LCD monitor, it's about two or three years old now. I'm well beyond the warrantee, before anybody tells me to just get it replaced. Here's the issue:

    When I leave my monitor alone for a long period of time (generally long enough for the screen saver to kick in), it stops working. Stops working as in: the screen turns completely black. The button which controls the power (it is GREEN when it's on, and ORANGE when the screen saver goes on) is a greenish-orange and when I press it, nothing happens, it simply stays lit.

    If I turn off the monitor while it's working, and THEN leave it alone, when I turn it back on later it STILL goes to this greenish-orange state of lockdown.

    The only way to fix this, as far as I've seen, seems to be by unplugging the monitor and then plugging it back in. When this first started happening, that worked immediately. Now, it seems like it takes many, many unplug-replugs to get it working. Sometimes that doesn't even work, and I have to go away for maybe 30 minutes and THEN try, and generally it will work.

    I really have no idea what the problem is or what to do. The problem isn't even consistent; there was a stretch of time where it constantly did this. Then I fooled around with screen saver/power options a bit, and it was fine for several weeks; operated completely normally. I also remember a time maybe a YEAR ago when it did this, and then stopped. Now it seems to be happening again. I don't like unplugging and re-plugging in my monitor over and over, I feel like it's probably only going to make things worse in the long run, so I'm asking you guys for help. Do you have any idea what to do about this?
     
  2. mattyc

    mattyc

    Joined:
    Aug 21, 2007
    Messages:
    417
    Do you have access to a second monitor to test on this PC, or a second PC to drive this monitor?

    Is the monitor getting hot? Is the room warmer than normal today?

    Does the monitor have an external power brick, or an internal one?

    Try lowering the resolution and/or refresh rate and see if that helps at all.
     
  3. RaptorJesusDesu

    RaptorJesusDesu Thread Starter

    Joined:
    Aug 23, 2007
    Messages:
    7
    I do not have a second PC or a second monitor, sadly.

    The power brick is internal.

    This probably is the warmest room in the house (entirely because the PC is in here) however it's been VERY cold compared to the rest of the summer lately, so I don't see why a problem would arise. I'll try keeping the windows open though. The monitor itself isn't hot in any way that I'm able to feel it.

    The refresh rate has been at its minimum for some time (60 hertz)

    If it happens again I'll try putting the resolution down. 1280x1024 is the "natural" LCD setting though, right? Whatever that means...
     
  4. mattyc

    mattyc

    Joined:
    Aug 21, 2007
    Messages:
    417
    Its going to be hard to pin blame on the monitor or pc without being able to mix and test.
    The only reason I was suspecting a heat issue is because you mentioned having to wait some time before getting the monitor to work correctly.

    What are you screen saver settings, and power saver settings for the monitor?
    Does the monitor ever lock up when you are actively using it?
    Maybe something is going on with your video card when it tries to put the monitor into power saving mode.
    You could try turning off the screen saver, and setting the monitor to never turn off.
    See if the monitor ever locks up that way.
    Then try setting the monitor to turn off after 10 minutes. See if you can get the monitor to turn back on just by using the mouse or keyboard.
    If the monitor locks up that way, try switching it so the screen saver turns on, but the monitor is set to never turn off.
    What type of screensaver is it? anything graphic intensive?
    And is it something silly like the pc trying to turn on the screen saver and turn the monitor off at the same time?
     
  5. RaptorJesusDesu

    RaptorJesusDesu Thread Starter

    Joined:
    Aug 23, 2007
    Messages:
    7
    It never, ever goes out while I'm on the computer; it's always once I leave it. So I'm thinking is must have something to do with screen saver/power settings.

    The way (I think) I fixed this originally was setting my monitor to turn off "Never" in power options. Oddly enough it happened again though today, after a few weeks of perfection.

    My screen saver was set as the Windows Logo, static in the upper right hand corner. Nothing intensive.

    I'm using Omega Drivers right now instead of the usual ATI stuff, that might be it, but I HAVE had this happen with the normal ATI drivers installed as well (just a long time ago).

    I'm going to try just turning off the saver...
     
  6. RaptorJesusDesu

    RaptorJesusDesu Thread Starter

    Joined:
    Aug 23, 2007
    Messages:
    7
    I'm using another computer to drive the monitor and it doesn't work. The problem definitely lies in the monitor; I mean, this happens even when its plugged into no computer at all. If I plug the monitor into ANY power source, the power button immediately flicks onto that orange-green and I can't turn it off or on, its completely unresponsive. It gets no signal, it doesn't even show the "no signal" sign, its just blank.

    I understand there's wear and tear with these things, but I've done nothing extreme to my monitor. Is it normal for it to just break like this??? Should I take it to MicroCenter to get it fixed?

    I think I've finally found a case with a similar problem. Considering the problem is entirely with the LCD, and the fact that it involves me needing to plug/unplug it to work, it seems like the problem is a dying voltage invertor. If I get that replaced I might be able to get it working again.
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/614294