1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Monitor problem...

Discussion in 'Hardware' started by spawnofh3ll, Apr 10, 2010.

Thread Status:
Not open for further replies.
Advertisement
  1. spawnofh3ll

    spawnofh3ll Thread Starter

    Joined:
    Apr 10, 2010
    Messages:
    2
    hey guys!
    actually my monitor doesn't work since 3 days ago: the monitor doesn't light up but the picture is visible if i point a flash light to it, the power light is working and there was a strange buzzing sound coming from it until recently...
    i've been researching a little and heard that bad capacitors on the "power-board-thing" could cause this problem so i've disassembled my monitor and checked it.
    the capacitors seem to be alright but i found something that apparently blew up...i think it's a fuse but i don't have that much experience with electronics and wanted to ask what that thing is, if it's possible to switch it with a new one and if possible where to get it...
    my monitor model is acer p193w, 19 inch widescreen

    here are some pics:
    http://www.pictureupload.de/originals/pictures/100410154506_10042010002.jpg
    http://www.pictureupload.de/originals/pictures/100410154628_10042010009.jpg

    i hope you can help me...thanks^^
     
  2. leroys1000

    leroys1000 Banned

    Joined:
    Aug 15, 2007
    Messages:
    6,319
    Yes it is a fuse.
    Looks like a 3 amp wirewound.
    The value is there on the board and it needs to be replaced
    with the same one.
    You can probably find one at an electronics parts store or
    radio shack maybe.
    Problem is,something caused it to blow,so there is probably
    another bad component somewhere that needs to be found
    and repaired.
     
  3. spawnofh3ll

    spawnofh3ll Thread Starter

    Joined:
    Apr 10, 2010
    Messages:
    2
    thank you for your reply...
    i will look around for that 3amp 250v fuse....i almost went and bought a 2amp fuse because i thought that the T2A meant 2 amp ^^
    i checked the "graphics-board" on the left and there's nothing wrong with it...that means the problem must be on the right board...



    Edit: i noticed something else...there seem to be burn marks on the other side of the board:
    http://www.pictureupload.de/originals/pictures/100410174329_e3.jpg
    http://www.pictureupload.de/originals/pictures/100410174123_e2.jpg
     
  4. leroys1000

    leroys1000 Banned

    Joined:
    Aug 15, 2007
    Messages:
    6,319
    Sorry looked like a 3 to me.
    Probably is a 2 amp.
    Hard to see in the pics.

    That unit in the other pic is a bridge rectifier.
    Probably want to check it for shorts or open circuits.
    Still probably other problems in the circuit as that heated too.
    The big capacitor is the filter cap for the power supply.
    Those 2 transistors on the heatsink may be the regulators.

    Might check ebay to see if anyone is selling that power board.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/915983

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice