Motherboard sb_pwr light comes on but nothing else

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

MlSO

Thread Starter
Joined
Sep 5, 2018
Messages
1
A while ago my pc randomly crashed while I was playing a video game and refused to respond to the power button so I did the PSU test and the PSU was fine so I purchased a new motherboard and recently put it back together but the computer still won't start, the motherboards "sb_pwer" led lights up but when I press the power button nothing happens, I purchased a power button and tried that but no luck. I just purchased a motherboard speaker and plugged it in hoping it would help me solve the situation but when I press the power button it doesn't even make any noise. I'm utterly confused at this point id appreciate any help. btw not even the case fans or individual fans will start.

I tried using another PSU from my current pc and it still did not turn on but for a while, it would turn the CPU coolers lights on but not post, everything else would not turn on at all, the different PSU doesn't even make the CPU cooler light up anymore

btw I tested putting everything together on cardboard and still no luck
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top