Mouse work on some usb ports not work on others

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Xynd

Thread Starter
Joined
Feb 17, 2004
Messages
377
Hi Guys

My computer has 2 usb ports in front & 4 at the back.
The problem is my mouse work when plugged in front but not work when plugged at the back.
The light on the mouse is on but the cursor just won't move.
I tried plugging flash disk at the back ports and they all works fine.
Please help.

Thank you
 
Joined
Jan 14, 2013
Messages
137
Hi,

What type of motherboard do you have and do you happen to check the specifications particularly with its onboard USB ports. Just thinking maybe you got USB 3.0 at the back and you're mouse is not compatible with it.
 

Xynd

Thread Starter
Joined
Feb 17, 2004
Messages
377
My motherboard is Asus P5GCMX
I believe all ports are USB2
 
Joined
Jan 14, 2013
Messages
137
Yeah, That MoBo has 2.0 all. Though other devices works properly at the back, you can still try these steps:
- reset BIOS to default
- update your USB driver or completely uninstall and reinstall it.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top