MP3 Player Problems...very annoying.

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Randomer1

Thread Starter
Joined
Dec 25, 2005
Messages
7
It got a Sanyo HDP-M3000 mp3 player for Christmas, and when I connect the player to the PC with the USB cable it is not recognised at all. No icon or "Removable Drive" symbol appears in My Computer and the connecting screen on the player disappears after about 5 seconds.

I tested it on my brother's laptop which is Windows XP and it all works fine with the mp3 drive appearing.

Is my Windows ME software too old? Am I missing a drive or something? The player was supposed to work with Windows ME.

Sorry if this is the wrong place to ask for help, it's just I know hardly anything about PCs and it's so disappoitning that I cannot work this thing. :confused: Any advice would be greatly appreciated.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top