1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

msgsrv32 error on boot

Discussion in 'Earlier Versions of Windows' started by Jim Tillage, Dec 28, 2001.

Thread Status:
Not open for further replies.
Advertisement
  1. Jim Tillage

    Jim Tillage Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    33
    Thur Dec 27,'01

    msgsrv32 error on boot after reinstall

    Recently I had a hard computer crash when I cancelled
    a particular program on my machine. It corrupted a lot of
    files, including a good many of Norton System Works 2001
    files, as well as a good many windows core files.
    I fixed a lot of the others, but decided to uninstall
    and reinstall NSW. Now when I boot to windows desktop all I
    get is "MSGSRV32 ERROR", with no icons and nothing loading
    in systrey. When I boot to safe mode I get the same error
    message. In neither screen can I get details of the error
    message. I am able to boot to command line prompt, but am
    not sure how to uninstall from there. I can find nothing in
    Norton's knowledge base on how to do this. Please help and
    elaborate on the proceedure to do this.

    I did a full install of the whole works. Everything. There
    was nothing in the readme.txt file that indicated I should
    not do a full install.

    Fri Dec 28,'01

    Here is all the things I inadvertantly let out in my haste
    to post.
    1. I did run Norton disk doctor in DOS, no problems.
    2. I did try rescue disk, it said not advisable to reload
    cmos, boot partition and (whatever) because it did not find
    anything wrong during scan.

    Also, upon further searching in DOS i found out I did a poor
    job of replacing corrupted windows files. There are at least
    50 pages of DOS "screens" with files that are possibly
    still corrupted.

    I am considering overinstall of windows to correct all those
    files unless there may be a better or easier way. I would
    appreciate instructions on how to do this, if possible.

    I now realize some of my mistakes, but hey, they aren't my first nor will they be my last, sigh!

    Please advise.

    Thanks to all who respond in advanced.
     
  2. Davey7549

    Davey7549

    Joined:
    Feb 28, 2001
    Messages:
    11,584
    Jim
    Welcome to TSG!
    Here is an error message that is pretty close to the one you described and the fix from Norton/Symantec for the error.
    Keep us posted on your progress.
    Dave

    Click Here for article.
     
  3. Jim Tillage

    Jim Tillage Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    33
    to davey7549

    I have completely searched thier website several times but cannot find
    any information that answers my main question, which is how to best
    accomplish the removal in DOS.
    As I explained before it hangs at the windows desktop with that error
    message, no icons loaded and not responding to a click on details.
    The very same thing happens when I boot to safe mode, no icons loaded and not responding to a click on details. I belive the
    only way is to try either removal in DOS or at the very least to
    rename the directories. (I tnink that would work). Please, somebody
    correct me if I am wrong.

    Thanks.
     
  4. Jim Tillage

    Jim Tillage Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    33
    With all do respect to everybody in this forum,
    is there the thought that maybe I should post this in the DOS forum?(just a thought).
    Let me know what you think.
    Thanks.
     
  5. Davey7549

    Davey7549

    Joined:
    Feb 28, 2001
    Messages:
    11,584
    Jim
    I was hoping someone well versed in DOS would have some idea and post. My experience is limited in DOS. If you click on the report to moderator link below you post ask them to move it to the DOS forum.
    Sorry Dave
     
  6. Bryan

    Bryan

    Joined:
    Jul 3, 1999
    Messages:
    11,943
    First Name:
    Bryan
    Jim, this should get you into File Manager and allow you to uninstall Nortons.

    Restart the PC and keep pressing F8 til you get the startup menu. Select option 6, "Safe Mode Command Prompt Only".

    Then type in Edit c:\windows\system.ini and press enter. Now change the line that reads Shell=Explorer.exe to Shell=Winfile.exe

    Now press the ALT key and then use the down arrow to highlight "Save" and press enter.

    Now press alt/ctrl/del to restart the PC. Assuming it now boots into "File Manager", click on File>Run and type in the following and press enter.

    control appwiz.cpl

    Now use Add/RemovePrograms to uninstall Nortons.

    When you restart the PC, be sure to boot back to the C:\> prompt and edit the System.ini file line from Shell=Winfile.exe back to Shell=Explorer.exe and save the changes. Then press press alt/ctrl/del to restart the PC and let it boot into Windows.

    Let us know what happens ........
     
  7. Jim Tillage

    Jim Tillage Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    33
    reply to Brian #1.

    To Brian, Thanks

    When I read your post I got excited, this sounds like a
    winner! However, here's the way it worked.

    I booted to safe mode command prompt only.
    changed the line to read as directed and C-A-D to reboot.
    It rebooted and ran Norton scandisk on drive C:\
    Continued on to same bootup screen as before-no icons,
    no start menu, Nothing, except msgsrv32 error and
    then hangs.

    I then tried hard boot.
    No luck. Still the same.:eek:

    Still hoping someone will come up with something.
    Although I'm beginning to think there may not be a
    simple solution.

    Thanks.
     
  8. Bryan

    Bryan

    Joined:
    Jul 3, 1999
    Messages:
    11,943
    First Name:
    Bryan
    Are you sure you remembered to save the changes to the System.ini file? Go back and rerun the Edit c:\windows\system.ini command and be sure the line does read

    Shell=Winfile.exe

    After you verify that the System.ini file does have the correct line, do this from a c:\> prompt

    ren autoexec.bat autoexec.xxx
    ren config.sys config.xxx

    Now press Alt/Ctrl/Del and see if it boots to FileManager now.

    As a last resort, if your running W98 or Windows ME, the other thing you can try if you can't boot to FileManager is a registry restore from a DOS prompt.

    scanreg /restore

    Use the Up/down arrows to select a registry copy dated the day of the Nortons uninstall/install or prior to it and press enter to restore it.

    BTW, if your running Windows ME, you need to boot to the Windows ME Boot Diskette, take the "Minimal Boot" option and then run the scanreg /restore command.
     
  9. Jim Tillage

    Jim Tillage Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    33
    To Brian,

    I did the shell=Winfile.exe back and forth
    several time and it didn't work.
    Also tried ren autoexec.bat and config.sys
    couple of times and that made no difference
    also. So I changed them back.And rebooted
    to check again.
    I am running win95 osr2 clone.
    I got to wondering if a copy of bootlog.txt
    could be of any help in diagnosing and/or
    finding a solution. It's too long
    to post, but I can email if it would help.
    I did notice that there are an awful lot
    of fonts that are not loading with a
    failure code 0016. Is there a way to do
    a system file check in DOS? Something
    like a win98 system file check, only do
    it in win 95. Maybe I should mention that
    I have Norton SystemWork 2001 installed on
    my win98 computer. So it is possible to
    access and transfer files with a floppy
    disk if that is any help.
    Thanks for hanging in there.
     
  10. Rollin' Rog

    Rollin' Rog

    Joined:
    Dec 9, 2000
    Messages:
    45,855
    A bootlog.txt might be useful but you would have to do a "logged boot" from the boot menu for it to be current. Otherwise it just reflects the original install, which typically produces a lot of font load fails which later are corrected.

    Since you have Win95 you don't have scanreg /restore as in Win98, you can however revert to the last successful registry -- system.da0 or even system.1st

    see this link:

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;q131431


    http://support.microsoft.com/default.aspx?scid=kb;EN-US;q136337
     
  11. Jim Tillage

    Jim Tillage Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    33
    Sorry for being so long to reply.
    I finally reinstalled win95 thru DOS.
    Everything seems to be okay except I seem to be missing dvd and cd-rom drives in device manager.
    I can read from both drives "E:\ +F:\". And they show up in "my computer".

    I am also missing primary and secondary controllers in DM, and all drives (C,D,E,F)are running in MSDOS compatibility mode file system.

    Primary controller is "SiS PCI IDE contoller", if that's any help.

    I have tried to find the appropriate downloads but that is all but impossible on thier web site, which is a joke.
    I have tried removing controller in DM and rebooting, but that doesn't help.
    At the risk of repeating myself, my system is:

    win95 osr2
    Pll 233mghz
    48megs memmory

    Any help would be appreciated.
    TIA.
     
  12. Mosaic1

    Mosaic1

    Joined:
    Aug 17, 2001
    Messages:
    7,486
    Download and install BelArc Advisor. Run it and paste the system specs it finds. Don't post the software information.

    Here's the link:
    http://www.belarc.com/Download.html
     
  13. Jim Tillage

    Jim Tillage Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    33
    To Mosaic1
    Good idea for getting a complete listing
    of one's system. I use it for myself regularly.
    Here is the latest.
    (Didn't mean to be so long replying but it seems
    I could not get to this site since Jan 10. on
    either of my computers).

    Computer Profile Summary
    Computer Name:*******
    Profile Date:Thursday, January 10, 2002 18:42:15
    Advisor Version:5.0h
    Windows Logon:*******

    operating System
    Windows 95 B (OSR2)


    Processor a
    233 megahertz Intel Pentium w/MMX Drives
    7.73 Gigabytes Usable Hard Drive Capacity
    4.53 Gigabytes Hard Drive Free Space

    Generic floppy disk drive (3.5")

    Controllers Standard Floppy Disk Controlle
    Creative Labs IDE controller
    Primary SiS IDE Controller
    Secondary SiS IDE Controller
    SiS PCI IDE Controller Bus Adapters None detected
    Communications SupraMax 56i [Modem]
    Microsoft Virtual Private Networking Adapter

    System Model
    No details available

    Main Circuit Board
    BIOS: American Megatrends 062600 07/15/

    Memory Modules
    46 Megabytes Installed Memory

    Local Drive Volumes
    c: (on drive N) 6.45 GB G4.12 GB free
    d: (on drive N) 1.28 GB 408 MB free

    Network Drives


    Printers
    Compaq IJ1200 on LPT1:
    Compaq IJ1200 on LPT1:
    HP LaserJet 5L (PCL) on LPT1:
    HP LaserJet 5L (PCL) on LPT1:

    Display
    SiS 5597/5598 [Display adapter]
    Super VGA 1280x1024 [Monitor]

    Multimedia
    Creative Sound Blaster 16 Plug and Play
    Gameport Joystick (no joystick connected)
    Wave Device for Voice Modem

    Other Devices
    Standard 101/102-Key or Microsoft Natural Keyboard
    Standard Serial Mouse
    ----

    I have noticed some things that I have questions about.
    One is concerning is the heading "local Drive Volumes"
    What does it mean "c: (on drive N)? The sizes of the
    drives are correct.
    Another question is Why does it not show that I have one
    Linksys and one Netgear cards in/on my system
    Let me remind everybody that all my drives are running
    in "MS-DOS compatibility mode ".

    I hope what I'm posting will help diagnose the problem.
    If not, let me know what you need.
    Thanks in advance.
     
  14. Bryan

    Bryan

    Joined:
    Jul 3, 1999
    Messages:
    11,943
    First Name:
    Bryan
    Try downloading and installing SIDE213.exe from <a href=http://www.sis.com/support/driver/utility.htm> here<a/>. Once it's done, restart Windows and see if your IDE controllers are ok after that. That should also fix your compatibility mode problem, too.

    Let us know what happens.
     
  15. Jim Tillage

    Jim Tillage Thread Starter

    Joined:
    Dec 28, 2001
    Messages:
    33
    To Brien,
    Thanks a lot,that fixed my primary and
    secondary SiS ide controllers. However,I
    temporarily tripped myself up when I tried
    to get my E:\ & F:\ (cd-rom & Cendyne
    16 x 10 x 40x burner, repectively) out of
    MS-DOS compatibility mode, which I have not
    yet figured out how to do.

    Some of my screwing around caused to me to be
    unable to connect online, but I seem to have
    resolved that issue.

    I have also become worried that my C hdd may be
    on the verge of failing, it seems to sometimes
    make a disturbing noise when booting up. I am
    going to install DriveCopy 3.0 and try to copy
    to disk.

    One good thing I can say is I belive I was
    able to make a cd-backup up of my D:\, and a lot
    of the stuff on C that I wanted to save, at least
    it can be read on my win98 machine. So guess it
    must have been written too. But E & F
    drives are still in the same mode.
     
  16. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/63319

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice