Music Album Art all over the place

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

bradley27

Thread Starter
Joined
Jul 15, 2008
Messages
354
I have as mentioned in a previous thread large MP3 collection which is also wired into itunes as i am one of the handful of people in the world still using the ipod Classic music player when on the move or driving.

For a long while now i get random album art for songs i have in my collection appear on other songs that are on playback.

Why does this happen? Its totally incorrect and this appears when playing them through Windows Media Player, itunes and on my ipod.

Any ideas on how to reset and correct this would be great? Thx
 

Oddba11

Jim
Joined
May 12, 2011
Messages
8,394
I would start by opening the file(s) that are having the "issue" and see what album art is actually attached to the file. mp3tag should still work for this (I haven't used it in years and I've been using MediaMonkey for quite a while now). In other words, verify the art actually in the file.

Assuming it's wrong, it would need to be fixed. There are automated options, but they aren't totally reliable. I fixed all of mine manually (using MediaMonkey), but again, a tool such as mp3tag should be able to do it.
 

bradley27

Thread Starter
Joined
Jul 15, 2008
Messages
354
Its alot of MP3s, get this so just yesterday i downloaded some Chicago albums and one of those album covers that must be attached to those files now shows up on other MP3s when i double click to play them....

I just downloaded MP3tag but i also saw you said it isnt too reliable? Thing is i can probably find the time to work through all of these hundreds of MP3s but i want to at least know that what i do wont result in the same thing happening again to all of them down the line....

Im also wondering what causes this to happen as its clearly a 'bug'.
 

Oddba11

Jim
Joined
May 12, 2011
Messages
8,394
Sounds like something is corrupt with the software being used.

And no, I didn't mean to imply mp3tag isn't reliable. It's been around for years and used to be the goto program for fixing mp3 files. But most media programs now have that ability built-in, so I haven't used it in a long time.

I was never a fan of iTunes, even when I was using my iPod. I ditched iTunes for a different media player and used a third party app to manage my iPod.
 

bradley27

Thread Starter
Joined
Jul 15, 2008
Messages
354
Okay so im doing the painstaking removal of album art for all of the MP3s that have album art embedded via MP3tag.

I am wondering though how i clear or delete any standing WMP cache.

Ive basically run through 260 files in a folder for 80s stuff and also confirmed/deleted one album cover in particular thats currently on literally all of the songs by different bands/artists in the WMP library album view tab BUT its still showing even though its been removed off the track it was embedded on when i downloaded a few days ago...So thats quite weird which leads me to think i have to delete hidden files somewhere to reinforce this?
 

Oddba11

Jim
Joined
May 12, 2011
Messages
8,394
Now I'm confused, I thought we were dealing with iTunes? The art issue is only in WMP?
 

bradley27

Thread Starter
Joined
Jul 15, 2008
Messages
354
When im in my car with the iPod connected i have a screen that projects the songs and has an album art preview too, those are all messed up too.

To give you an overview:

I have a very large MP3 collection sorted into about 35-40 different folders, E.G 80s, Alternative/Rock, Funk, Disco, Rare Groove, R&B, Urban/R&B...In some cases i have a folder for say..Michael Jackson, Prince, Pink Floyd, Genesis & Phil Collins, Queen, Whitney Houston as i have so much of their material.

Many but not (all lets say about 45%) of the 6,000 songs have album art embedded in them so at some stage something has corrupted or ive not set things up correctly so this is where im seeing one particular album cover being projected on all of the songs in the 80s folder.

Im using MP3tag right now and painstakingly working through all of them to remove the art work so it eliminates that happening. But what i will also need to do is flush the wmp album art cache (wherever that is) and hopefully that will be the start of the fix.

Itunes is basically reflecting the data it has from the MP3s in WMP so no suprise that it all looks so messed up.
 

bradley27

Thread Starter
Joined
Jul 15, 2008
Messages
354
Cheers, used MP3tag which is indeed a pretty good little program actually to rid every MP3 that had album art and then it also corrects/updates the MP3 tag type, i had about 25 mp3s that were listed as BAD so thats fixed those too i think. The link you posted also guided me to pretty much wipe WMP so its all fresh and no album art mix ups anymore. Im also restoring my iPod classic with a new battery and SD card board and retiring its harddrive so i should be all set now. Thanks
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top