1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

My Doc. Folder

Discussion in 'Windows XP' started by terryxp, Feb 6, 2003.

Thread Status:
Not open for further replies.
Advertisement
  1. terryxp

    terryxp Thread Starter

    Joined:
    Mar 30, 2002
    Messages:
    666
    Hey all... My PC has a mind of it's own. Won't let me delete my documents icon/shortcut from the desktop. Actually, it will delete from the desktop, but when I browse my hard drive from my computer, folder view, after I delete my doc folder, it will dissapear, but then when I close windows explorer, and reopen there it is back again. Minded, I'm only trying to get rid of the desktop view of my doc, not actually delete my doc folder. Kinda confusing, but I'm sending a screen capture of windows eplorer view, where you can see why I would want to delete the desktop view, notice the 2 branches, for Terry's Documents, (my documents renamed)
     

    Attached Files:

  2. Del

    Del

    Joined:
    Aug 31, 2001
    Messages:
    3,452
    It's a protected folder as with Win ME. If you do a system restore, it protect everything in My documents, including My music and My pictures.
    If you do a system restore, it will not touch My Documents folder.

    Go to help and read up on system restrore.
     
  3. terryxp

    terryxp Thread Starter

    Joined:
    Mar 30, 2002
    Messages:
    666
    I've never used system restore, I use roxio go back, but anywho, I'm not trying to delete my documents folder.... "just the desktop view", shortcut etc......................................................................
     
  4. Huon

    Huon

    Joined:
    Aug 16, 2002
    Messages:
    429
    The answer is TweakUI, part of the MS powertools for XP
    www.microsoft.com/windowsxp/pro/downloads/powertoys.asp
    That enables you to remove it, and do some other cool customisations and other useful things. (for remove, read hide..)
    There is probably a reg hack for what you want, but the powertools are easier.:)
     
  5. NameTooLong

    NameTooLong

    Joined:
    Dec 26, 2002
    Messages:
    325
    I have a non-software solution for your problem. Right click on the desktop, go to properties. Click the desktop tab and click on customize desktop. Uncheck all you don't want. Though TweakUI is still worth getting.
     
  6. terryxp

    terryxp Thread Starter

    Joined:
    Mar 30, 2002
    Messages:
    666
    lolol... yea, ok... thanks for the advice, but I had already tried the obvious. The problem is, after I make the change in the display applet, to hide the desktop my doc shortcut "IT DOES NOT WORK"
    Alrighty then.... as to say, it does remove it from the desktop, but it is still there in windows explorer.
    And tweakui for winxp, the powertoy, does not have the option for what I'm trying to do, unlike the version of tweak for older windows versions....

    Thanks anyway
     
  7. Mosaic1

    Mosaic1

    Joined:
    Aug 17, 2001
    Messages:
    7,486
    That folder pane looks odd. You have one My Documents which is not using the Shell Icon and another which is. Are they exactly the same?


    Are you using the New Start Menu? Here's the registry key which controls whether or not My Docs appears on the desktop. After you change this key you have to refresh the desktop.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel

    Click NewStartPanel in the left pane. Look in the right pane for this Value:

    {450D8FBA-AD25-11D0-98A8-0800361B1103}

    Double click on it. Change the value to 0 to show MyDocs or 1 to hide MyDocs on the desktop.

    Click OK. Close the registry. Refresh the desktop.

    I forgot to tell you how to change it if using the Classic Start Menu. Everything is the same but this is the key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu


    And I would also register Mydocs.dll again.

    Start>run

    regsvr32 mydocs.dll
    Press enter.
    Reboot.
     
  8. terryxp

    terryxp Thread Starter

    Joined:
    Mar 30, 2002
    Messages:
    666
    Nah, nothing worked... The 2nd mydoc folder is different, it has a piece of paper like dealy sticking out of it. I am using "new" start menu. When I go into the display applet, you know, right click on the desptop, and choose "desktop" "customize" and select mydoc folder for hiding, it does hide it on teh desktop, so the icon is no longer on the desktop, but it is visible everywhere else, like in windows explorer, or powerdesktop. If I enable the desktop toolbar on the taskbar, it is visible there as well, while supposing to be hidden??? My head hurts
     

    Attached Files:

  9. Mosaic1

    Mosaic1

    Joined:
    Aug 17, 2001
    Messages:
    7,486
    The one with the paper is the desktop shortcut.

    The other is normal. The entry you checked only removes the icon from the desktop. Have a look at the Save As Dialog. My Computer and My Network Places still appear too after you choose to hide them. Same goes for the Explorer Folders Pane.

    There's nothing wrong with your OS.
     
  10. Mosaic1

    Mosaic1

    Joined:
    Aug 17, 2001
    Messages:
    7,486
    To remove the My Documents Shortcut icon from the dialogs etc try this.

    Open the registry and navigate to:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{450D8FBA-AD25-11D0-98A8-0800361B1103}

    Right click on {450D8FBA-AD25-11D0-98A8-0800361B1103}
    and choose export. Save this in a safe place so that you can have the option to put it back.

    Now Delete the key. This is the My Documents Desktop Namespace.

    Log off and back on to show the difference. Explorer has to be restarted for the change to be implemented.

    Explorer will no longer show the shortcut My Documents under Desktop either unless you use the Accessories>Explorer which opens to it as default. Change that to open elsewhere and I think you will have what you wanted.
     
  11. Mosaic1

    Mosaic1

    Joined:
    Aug 17, 2001
    Messages:
    7,486
    I never use the Accessories Explorer shortcut and so it looked strange to me. At any rate, XP is a bit different fomr 98 . If you want to cahnge the default to open not in My Documents but instead in My Computer. Right click on the shortcut and choose properties.


    Change Target to this:

    %SystemRoot%\explorer.exe /n,/e,/
     
  12. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/117299

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice