1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

my graphics card works but not in my pc :-(

Discussion in 'Games' started by kreedorz, Jun 18, 2019.

Advertisement
  1. kreedorz

    kreedorz Thread Starter

    Joined:
    Jun 18, 2019
    Messages:
    5
    i'm having a pc with a specs:
    intel core 2 duo
    g31/33 motherboard
    4gb ddr2 ram
    and GeForce 210

    my pc works fine without graphics card but wont run any game ,if I connect my gpu it wont display showing no connection.
    I gave my gpu to my friend and try running on his pc , but it doesn't work
    he tried to repair it with putting his own efforts and finally it works ,
    his pc specs are:
    intel core 2 duo
    g31/33 motherboard
    2gb ddr2 ram

    it is same as my pc specs but differ in motherboard brand and he has lesser amount of ram.

    so if I try to run it in my pc it wont work ,why ?
    is this a fault of bios ?
    (phoenix award bios)

    I have to mention that I have no money to buy a new one.
     
  2. lochlomonder

    lochlomonder

    Joined:
    Jul 24, 2015
    Messages:
    2,591
    Check your BIOS settings. I've seen older machines where you have to specify you're using an external video device in BIOS; it doesn't switch automatically. You may have to make this modification before the card will display properly.
     
  3. kreedorz

    kreedorz Thread Starter

    Joined:
    Jun 18, 2019
    Messages:
    5
    ok i'll try it later and then tell if it is working or not .
     
    lochlomonder likes this.
  4. kreedorz

    kreedorz Thread Starter

    Joined:
    Jun 18, 2019
    Messages:
    5
    i tried it and it worked first till windows start up at the loading and i waited for a long time and then i restart my pc and the same problem occured , i tried multiple times and dosent work i don't know what to do now.
    the problem i face seems to be unsolved, please help
     
  5. lochlomonder

    lochlomonder

    Joined:
    Jul 24, 2015
    Messages:
    2,591
    Does this mean you can see something on the screen when you first boot up, and then it goes away as Windows loads?
     
  6. ZephrSantana

    ZephrSantana

    Joined:
    Jun 21, 2019
    Messages:
    2
    maybe try to buy new cables for the card?
     
  7. kreedorz

    kreedorz Thread Starter

    Joined:
    Jun 18, 2019
    Messages:
    5
    no ,it worked only for the first time and then it doesn't display anything only showing no display like the first time . i did many restart but still it shows no display.

    the problem is with the mother board bios and the mother board manufacture .they didn't give a bios update to their web page to update bios . it's a crappy motherboard. but still something is missing ,i need help.
     
  8. kreedorz

    kreedorz Thread Starter

    Joined:
    Jun 18, 2019
    Messages:
    5
    the cables seems to be working fine , i even tried connecting to my TV with HDMI port.
     
  9. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...

Short URL to this thread: https://techguy.org/1228788

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice