My Kodak EasyShare Z1275 won't take pictures!

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

magicmarqer12

Thread Starter
Joined
Oct 8, 2008
Messages
1
For some reason unknown to me, whenever I try to take a picture with my Kodak EasyShare Z1275 the screen just turns black, the power light turns off and so does the blue light when you turn it on! Nothing happens when I switch to different modes and the lens don't recede either! I can't exactly send it back as we're leaving in four days for a wedding and the company doesn't ship quickly enough! So if anyone has any idea what I'm talking about and how to fix it please let me know immediatly!
 

buck52

Banned
Joined
Mar 9, 2001
Messages
8,372
did it ever work correctly?
Have you tried fresh batterys?

If the wedding is important for you to record...quick go buy another disposable point and shoot digital camera... :)
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top