1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

My laptop keeps connecting to a different network than mine!

Discussion in 'Networking' started by supermanno, Nov 14, 2006.

Thread Status:
Not open for further replies.
Advertisement
  1. supermanno

    supermanno Thread Starter

    Joined:
    Jan 3, 2004
    Messages:
    148
    I have a problem: I have a wireless network which works great. Unfortunately for some reason my laptop keeps disconnecting from my netowrk and connecting to an outside netowork. Theres a bunch of wireless networks around here (some of which unprotected with password) and my laptop keeps switching back and forth thus disconnecting me contiually. I put my wireless network on top priority in the advanced tab, but to no avail. Is there anything I can do so that my laptop stays connected to my network? Also I go to my university and use their wireless network, so I dont wanna completely switch off all other networks, as sometimes I do need to connect to them. How do I go about doing this?
    thank you very much
     
  2. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,409
    Set it to only connect to preferred networks.
     
  3. foneguy9

    foneguy9

    Joined:
    Sep 19, 2006
    Messages:
    196
    Hi Supermanno,

    A few questions for you...

    Are u using the Windows Wireless Network Connection?

    Also, what kind of signal strength are u getting with your network? Have you secured your network?

    Assuming the Wireless Network Connection that comes with Windows:
    If you go to the Wireless Conection Properties
    Wireless Networks Tab
    Under Preferred Networks
    Select each of the 'other' networks that you DO NOT want to connect to...
    Press the Properties button
    Go to the Connection TAB
    UNCHECK the box, Connect when this network is in range.
    Click OK...

    Of course, this will be different if you are using a proprietary Wireless connection software....
     
  4. foneguy9

    foneguy9

    Joined:
    Sep 19, 2006
    Messages:
    196
    As JohnWill mentioned, this would be the easier way to do it...:)

    If you go to the Wireless Conection Properties
    Wireless Networks Tab
    In the Preferred Networks press the Advanced Tab
    At the bottom of that window you have a check box to Automatically connect to non-preferred networks. Make sure it is UNCHECKED.

    That should be it....

    JohnWill is ALWAYS right on...:D
     
  5. supermanno

    supermanno Thread Starter

    Joined:
    Jan 3, 2004
    Messages:
    148
    My signal is very strong and is secured. But also the other signals are strong. Its kind of funny... the other wireless networks dont show up on my preferred network list BUT they show up in the "choose a wireless network" window. WHats the deal?
     
  6. foneguy9

    foneguy9

    Joined:
    Sep 19, 2006
    Messages:
    196
    K,
    So those Networks don't have a little Yellow Star on the upper right hand side of the bar of the 'Choose a wireless network'? This indicates a preferred network.
    Did you also try what JohnWill suggested from the Advanced Button? That should fix you up straight away.
     
  7. supermanno

    supermanno Thread Starter

    Joined:
    Jan 3, 2004
    Messages:
    148
    The only network with the yellow star is my network. I dont see any tab saying "only connect to preferred networks".
     
  8. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,409
    The option is to allow connections to non-preferred networks, you uncheck it if you only want to connect to networks in the preferred list.
     
  9. ucHiha itacHi

    ucHiha itacHi

    Joined:
    Nov 8, 2006
    Messages:
    22
    I hope you guys don't mind if I butt in..

    I would just like to say that this problem is a very common problem especially if the wireless computer is in a location with a lot of other wireless networks.

    The way Windows XP behaves (the Wireless Zero Configuration service, in particular) is that it will always try to connect to the strongest 'open' network. Open meaning, no encryption. Since your network has encryption, that explains why your operating system rather chooses connecting to the other network which is of equal strength to yours.

    Since you mentioned Preferred Networks, I will be assuming that you are using Windows XP' Zero Utility (WZCSVC) instead of some proprietary programs. This would explain why the computer keeps on hopping to other networks.

    You see, the way it works is that every time the computer loses a connection (to your router/network), it will automatically connect to the next preferred network on the list. How to get around this? Remove all the other preferred networks, or better yet, delete all preferred networks. Simple as that. After you've done that, connect the laptop to your network so that Windows XP creates a 'profile' for your connection (a Preferred Network listing)

    All in all, what this does is that it basically tells your computer to only connect to your network. Now, once you connect to another network, it will create a preferred network listing and that's something you will have to remove manually if you don't want the annoying network hopping brouhaha.

    Hope it helps. Thanks
     
  10. supermanno

    supermanno Thread Starter

    Joined:
    Jan 3, 2004
    Messages:
    148
    Dont mean to sound redundant and I really appreciate you guys help... but as I said the only network in the preferred list is my network. How do you explain the switching back and forth?
     
  11. JohnWill

    JohnWill Retired Moderator

    Joined:
    Oct 19, 2002
    Messages:
    106,409
    Did you uncheck the option I mentioned?
     
  12. TerryNet

    TerryNet Terry Moderator

    Joined:
    Mar 23, 2005
    Messages:
    69,586
    And if you still have the problem after John's "uncheck the option I mentioned," put WZC out to pasture and use the adapter's utility. I've read that sometimes no matter what you do WZC still insists on momentarily disconnecting to look for a "better" signal.
     
  13. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/518294