my mouse had stopped working???

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

melpa

Thread Starter
Joined
Jan 14, 2011
Messages
9
I've had this problem on and off now for the past 4-5 month's, and the main problem is when researching what the problem is, I have had no luck and what i seem to have is rare? My mouse (when working) is never 100% but does what I need, and is always a little stiff and it will work for a good 1-2 month's and then slowly it will start to stiffen even more, making it very hard to move and then bang and is completely stuck! this takes all takes place in about 20 minutes when i know its going to happen and there is no preventing it. the strangest part of it all is that when it is stuck, if i leave the mouse alone for a couple of minutes it will be fine and can move it a couple cm's before its stuck again. it took me 15 minutes to get to this website and had to keep leaving it and then moving it and so on.. so i really hope someone replies!! thanks!

p.s. both my USB and wire mouse dont work, I've checked the drivers and it says its up to date.
 

melpa

Thread Starter
Joined
Jan 14, 2011
Messages
9
update: when i mean 20 minutes, i ment the process of the mouse getting slower and slower takes place in that time, but this whole problem can last up to 10 days sometimes :(
 
Joined
Oct 13, 2003
Messages
3,033
Does the mouse need a new battery?
The wired one should work, unless Windows is confused, which driver to use.
Have you tried uninstalling the mouse from the Device manager? Windows should recognize it next time you start up computer.
If none of this works, you could have a virus. Do you have an updated version of Malware protection?
What version of Windows do you have?
What brand of mice do you have?
 

melpa

Thread Starter
Joined
Jan 14, 2011
Messages
9
hey bp936! thanks a lot for the reply, much appreciated! Yeah i changed the battery's and it seems to work a little better, so am going to do a virus scan as i speak and will post the reults to what comes up. thanks again.
 
Joined
Oct 13, 2003
Messages
3,033
if your scanner finds something and still nothing has changed, run Malwarebytes
http://www.malwarebytes.org/
and Superantispyware:
http://www.superantispyware.com/


Otherwise read information here if you have Malware causing a problem:
http://forums.techguy.org/virus-other-malware-removal/943214-everyone-must-read-before-posting.html
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Members online

Top