1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

My new PC is having bad internet problems

Discussion in 'Networking' started by BludOvThaKreed, Sep 17, 2012.

Thread Status:
Not open for further replies.
Advertisement
  1. BludOvThaKreed

    BludOvThaKreed Thread Starter

    Joined:
    Sep 17, 2012
    Messages:
    2
    I just bought a new PC. Two of my friends and I built it together ourselves. Once we booted it up, we got the Windows 7 updates and all other required updates in practically no time at all (about 35 minutes total with a 20 Mbps download rate).

    Once I brought my new toy home however, it was a different story. I was only downloading things at 2 Mbps. I connected the internet directly into the PC, got rid of the splitter and it was still the same thing. My wireless Dell laptop was still picking up an 18Mbps download rate and 20Mbps rate when plugged in directly. I took my PC to a friend's house who has the same ISP and laptop and it had the same result. It has been 72 hours of frustration.

    Tech support from my local service provider insists that my IPv6 is not properly installed or something but I'm not so sure.

    What is the problem here? Please help.
     
  2. BludOvThaKreed

    BludOvThaKreed Thread Starter

    Joined:
    Sep 17, 2012
    Messages:
    2
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1069301