Nasty Little Virus

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

dlbutler

Thread Starter
Joined
Dec 23, 2011
Messages
128
I have 350gb Western Digital external drive that I using with my laptop to store music, movies and apps that I may happened to download or purchase . But recently I think I may have picked up a virus. Whenever I plug my drive into my laptop it doesn't show. Normally, whenever I plugged it up it would open Windows Explorer and show me what files were listed. Now, it doesn't do anything, and its a brand new drive. I mean, I only purchased it about 4 months ago.

Things that I've tried in order to get it working:

  • I tried running a scan on it but it doesn't show when I open Windows Explorer
  • I tried connecting it to another pc and scanning it, but it won't show on other pc's
  • I tried replacing the usb cable that connects it to my laptop, nothing!
Does anyone have any idea on what I can do, I have so many important files that I can't wipe it, I mean, I have over 1200 mp3's alone. Not to mention all kinds of other important data. Again, its a Western Digital 350gb external drive and it has a virus on it. Please, if there's anyone who can help with this I would be much appreciative.

Thank you
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top