Naviga~1.exe Virus?

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

killapreacha

Thread Starter
Joined
Apr 5, 2015
Messages
1
I have noticed in the last couple of days that I have an extraordinary amount of ram being used. 1.9 - 1.95 out of 2 Gigs. The only new process I've noticed is naviga~1.exe and from what I've researched it's a ransomware virus. But I can't find any information about removing it. Attached a screenshot of my resource monitor. Any help would be greatly appreciated.

Tech Support Guy System Info Utility version 1.0.0.2
OS Version: Microsoft Windows 7 Professional, Service Pack 1, 64 bit
Processor: Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz, Intel64 Family 6 Model 23 Stepping 10
Processor Count: 2
RAM: 1995 Mb
Graphics Card: Intel(R) Q45/Q43 Express Chipset, 773 Mb
Hard Drives: C: Total - 76316 MB, Free - 30296 MB;
Motherboard: Dell Inc., 0M858N
Antivirus: Microsoft Security Essentials, Updated and Enabled
 

Attachments

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top