Need help Removing LNK icons from desktop

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

boyletammy

Thread Starter
Joined
Apr 28, 2010
Messages
3
Some of my icons on my desk top have turned into LNK and i cant open them i need help fixing this PLEASE
 

Triple6

Rob
Retired Moderator
Joined
Dec 26, 2002
Messages
52,933
Welcome to TSG I have removed your email address from your post. You should not post your email address as the only thin you'll get is spam, all answers will be posted on this forum for you to view safely.
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
81,424
Depends on the option you have set for subscriptions. The default is to get email notification of replies. Sometimes it fails or is tardy, so my advice to anybody really interested in his/her thread is to check it for replies.

EDIT: At least, I think that's the default. It's been so many years ago that I turned it off that I don't really remember. )
 
Joined
Aug 7, 2007
Messages
9,028
Actually, most of the icons on the Desktop should be .LNK; that's the file extension for a Shortcut (Link) file. The Extension is normally set so it never shows, even when the system is set to not hide file extensions. I suspect the NeverShowExt registry entry is missing or corrupted. And if they no longer work, there may be other pieces that are missing or corrupted.

Go here:
File association fixes for Windows 7
and download the fix for LNK files.
To extract the file from the ZIP archive, double click on the downloaded file to open it, then drag the .reg file to your desktop.
Double click it to merge into the registry.

See if that gets them working, and not showing the LNK extension.
 
Joined
May 6, 2010
Messages
2
YOU DID IT! Many thanks. At first I wasn't certain if it worked because the Icons on the desktop and taskbar still looked the same (representations of Photo Viewer) but when I clicked on them, they actually opened up into the proper applications instead of just opening up Photo Viewer. I rebooted the computer, and to my delight all the Icons were displayed appropriately. Thanks a million. I was afraid I'd have to resort to a Factory Restore.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top