Need help with autohotkey

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

sharpiemufc

Thread Starter
Joined
Dec 27, 2010
Messages
1
Don't hate for this, I just want some honest help. :)

I have recently downloaded autohotkey, and have created a successful like bot for youtube, however, when trying to create a subscriber bot, a problem arises.

This is my code:

PHP:
WinWait, Program Manager,  
IfWinNotActive, Program Manager, , WinActivate, Program Manager,  
WinWaitActive, Program Manager,  
MouseClick, left,  1290,  66 
MouseClick, left,  1290,  66 
Sleep, 100 
WinWait, Google - Google Chrome,  
IfWinNotActive, Google - Google Chrome, , WinActivate, Google - Google Chrome,  
WinWaitActive, Google - Google Chrome,  
MouseClick, left,  104,  69 
Sleep, 100 
WinWait, YouTube - Broadcast Yourself. - Google Chrome,  
IfWinNotActive, YouTube - Broadcast Yourself. - Google Chrome, , WinActivate, YouTube - Broadcast Yourself. - Google Chrome,  
WinWaitActive, YouTube - Broadcast Yourself. - Google Chrome,  
MouseClick, left,  1136,  124 
Sleep, 100 
WinWait, YouTube - Google Chrome,  
IfWinNotActive, YouTube - Google Chrome, , WinActivate, YouTube - Google Chrome,  
WinWaitActive, YouTube - Google Chrome,  
Send, [Youtube Username]{TAB}[Password]{ENTER} 
WinWait, YouTube - [Youtube Username]'s YouTube - Google Chrome,  
IfWinNotActive, YouTube - [Youtube Username]'s YouTube - Google Chrome, , WinActivate, YouTube - [Youtube Username]'s YouTube - Google Chrome,  
WinWaitActive, YouTube - [Youtube Username]'s YouTube - Google Chrome,  
MouseClick, left,  445,  49 
Sleep, 100 
Send, {RIGHT}/[Channel to sub to]{ENTER} 
WinWait, YouTube - [Channel to sub to]'s Channel - Google Chrome,  
IfWinNotActive, YouTube - [Channel to sub to]'s Channel - Google Chrome, , WinActivate, YouTube - [Channel to sub to]'s Channel - Google Chrome,  
WinWaitActive, YouTube - [Channel to sub to]'s Channel - Google Chrome,  
MouseClick, left,  474,  184 
Sleep, 100 
MouseClick, left,  1122,  118 
Sleep, 100 
WinWait, YouTube - Broadcast Yourself. - Google Chrome,  
IfWinNotActive, YouTube - Broadcast Yourself. - Google Chrome, , WinActivate, YouTube - Broadcast Yourself. - Google Chrome,  
WinWaitActive, YouTube - Broadcast Yourself. - Google Chrome,  
MouseClick, left,  120,  80 
Sleep, 100
This works fine, so long as I record (using AutoScriptWrite) clicking the "Subscribe" button.

The problem is that when I change the username to someone else's, it does not click the subscribe button. Any help is greatly appreciated.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Staff online

Members online

Top