1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

need help with vista drivers please!

Discussion in 'Windows Vista' started by gtsak, Feb 6, 2007.

Thread Status:
Not open for further replies.
Advertisement
  1. gtsak

    gtsak Thread Starter

    Joined:
    Jan 8, 2006
    Messages:
    17
    to start off, i had windows xp home sp2 installed before i upgraded to windows vista home basic. i have a netgear wg311v2 wireless pci adapter installed and stopped working after i installed vista 3 days later. also, my lexmark x6170 printer and logitech clicksmart 510 aren't recognized AT ALL :mad: i tried everything from uninstalling to disabling to restarting after each change i've done and although the software was "successfully" installed the hardware chooses not to work.

    you would think they would have drivers ready for everyone's equipment after the upgrade, but unfortunately, they have to do everything the last minute. so if there are any alternatives to my problems that you know of, that would be great!
     
  2. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    38,834
    Have you checked the hardware makers site for drivers for your devices?

    Did you run the vista check BEFORE you attempted to install vista?

    Is this an upgrade or a clean install of vista?

    Also it would be a good idea to post exact specs on your system.
     
  3. gtsak

    gtsak Thread Starter

    Joined:
    Jan 8, 2006
    Messages:
    17
    like i said, i tried everything. even searched online. lexmark says "coming soon" for my printer yada yada yada. i did an upgrade, not a clean install. and yes i used the upgrade advisor and no conflicts were shown for the devices that dont work. its items that werent listed in the advisor that are giving me trouble....weird but true!! im thinking about doing a clean install when i get a chance cuz im using my mac until i get some questions answered.
     
  4. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    38,834
    I would do a clean install. XP and vista are very different and having the old drivers on there from xp could be a problem. Vista usually installs usb type printers without a problem however there is always the chance that because it is an all-in-one printer that it needs a specific driver.
     
  5. gtsak

    gtsak Thread Starter

    Joined:
    Jan 8, 2006
    Messages:
    17
    ok here's an update for those with similar issues on vista:

    1. For the NETGEAR wg311v2 pci adapter, completely uninstall it from the system (software, driver, and from the device manager). shut down vista, remove adapter from existing PCI slot and restart the computer. After bootup, make sure the netgear folder is deleted from your program files folder. do a new install of the latest netgear software including drivers. after setup, shutdown computer, insert adapter into a new PCI slot and restart. drivers will be installed upon new hardware detection, and you're all set!!!

    2. Logitech clicksmart 510: microphone will not install. drivers for webcam seem to be installed correctly, but have yet to try it.

    3. Lexmark x6170: wait for vista drivers. no luck in this department.

    **Basically, doing a clean install of your hardware on different ports/slots will help solve most issues, as far as my situation goes. hope this helps.
     
  6. dooburyfurkin

    dooburyfurkin

    Joined:
    Feb 6, 2007
    Messages:
    37
  7. gtsak

    gtsak Thread Starter

    Joined:
    Jan 8, 2006
    Messages:
    17
    found logitech mic drivers. will try them at home later. Great site!!!
     
  8. gtsak

    gtsak Thread Starter

    Joined:
    Jan 8, 2006
    Messages:
    17
    logitech camera once again works, but no mic. anyone aware of this problem?
     
  9. tjamnz

    tjamnz

    Joined:
    Jun 15, 2004
    Messages:
    774
    has he tried the device mangager.. search microsoft online option for driver update? Its worked for me a few times with xp, when i lost a driver cd or whatever.
     
  10. stonelee

    stonelee

    Joined:
    Oct 23, 2007
    Messages:
    1
    hello, gtsak. I have the same problem as you. I have a logitech clicksmart 510 and my computer system was ungraded to windows vista ultimate. I can not install 510 on my computer. I learn from your message that you successfully sovle the problem. could you please help by telling me how to install it? or where did you get the drivers for vista? thanks a lot in advance!
     
  11. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - need help vista
  1. proprboy
    Replies:
    3
    Views:
    700
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/541757

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice