1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Netbook fails to instail Linux. Tried EVERYTHING!!!!!

Discussion in 'Hardware' started by mapexmbirch, Dec 16, 2011.

Thread Status:
Not open for further replies.
Advertisement
  1. mapexmbirch

    mapexmbirch Thread Starter

    Joined:
    Nov 23, 2011
    Messages:
    88
    So I bought the netbook off ebay it had XP on it and it worked fine apart from a error message at start up, which you could press enter and it would start up fine. I wanted to fix this by downloading the driver that was corrupt, then when I restarted it came up with a new error message which I couldn't get past I took it into a computer shop as I didn't has a external disc drive. They wiped the hard drive and tried to put XP back on with the disc that came with the netbook. They found out the disc wasn't a resore and the XP didn't have a keycode (probably downloaded off pirate bay, the netbook came originaly with linux). I downloaded Linux mint and put it on a disc gave it to them and they installed it fine.

    I got a external disc drive in the post and I wanted to try ubuntu. So I installed that fine. Here is where I should of stopped.

    I then thought it would be good to put XP and dual boot. I created a partition for it and then tried to install it from the disc everything was ok untill I rebooted it to finish the instalation. It then said some files were missing and couldn't complete the instalation.
    When I rebooted after that it wouldn't do anything I thought it was ok. I would just wipe the hard drive using dban. I installed XP on one off the SSDs 32gb so I could wipe it if it went wrong and still have the 8gb SSD with linux on.
    Now it the setup part to choose what drive to boot from I have the cd drive first then i want to put the 8gb SSD with linux on it but it won't let me choose it, as in it is not on the list.
    I have tried reinstalling linux and i get right up to the part when it installs the bootloader the it says fatal error and so on. I can select the 8gb from linux installer but not from the boot squence menu.

    I am going to bed now and I probably can't reply untill tommorow afternoon. Any suggestions would be great.

    P.S I know that torrenting is against the rules but i can't turn back time.
    Thanks
     
  2. dvk01

    dvk01 Moderator Malware Specialist

    Joined:
    Dec 14, 2002
    Messages:
    56,452
    First Name:
    Derek
    In my experience, a Windows bootloader won't see linux , but a linux bootloader will see & give you the option to boot into windows

    Also XP doesn't normally recognize a SSD as a boot device without either a bios update or a special driver.

    see https://wiki.archlinux.org/index.php/Solid_State_Drives

    & scroll down to
    Warning: If you plan to dual boot with Windows (XP, Vista or 7) do NOT use GPT since they do NOT support booting from a GPT disk in BIOS systems! You will need to use the depreciated MBR method described below for dual-boot in BIOS systems! This limitation does not apply if you boot in UEFI mode and using Windows Vista (64bits) or 7 (64bits). For 32-bit Windows Vista and 7, and 32 and 64-bit Windows XP, you need to use MBR partitioning and boot in BIOS mode only.
     
  3. mapexmbirch

    mapexmbirch Thread Starter

    Joined:
    Nov 23, 2011
    Messages:
    88
    Thanks, I wish I saw that before.

    I have now erased the 32GB SSD that had XP installed on it and I have tried installing Linux again on the 8GB. It says installation complete but then when I restart it I just get a flashing cursor on a black back round. Now I have just erased the 8GB SSD and trying installing ubuntu again.
    On the install page where you choose between 'installing ubuntu' or 'choose something else' if you click on choose something else it comes up with:
    /dev/sda
    /dev/sdb

    sda is the 31GB and sdb is the 8GB. When I select either of them it comes up 'no root file system defined, please correct this using the partitioning menu.'

    I don't understand why wiping the hard drive doesn't start from scratch. It should be like a brand new computer and should have no problems with installing.
    I used a program called dban to erase I read somewhere (as I was erasing the SSD) that dban has not been designed for SSDs. But it was too late. Maybe this is the problem, dban has damaged the SSD's.

    I am now doing the 'erase hard drive and install ubuntu' option and I will get back to if it works. If that doesn't work then I will try and install it on the 31GB SSD.
     
  4. mapexmbirch

    mapexmbirch Thread Starter

    Joined:
    Nov 23, 2011
    Messages:
    88
    It worked!!

    Thanks for the link it maybe useful at some point.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Similar Threads - Netbook fails instail
  1. Malice32
    Replies:
    1
    Views:
    124
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1031557

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice