1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

Network location stuck in "Public"

Discussion in 'Windows 7' started by Jadan, Apr 27, 2015.

Thread Status:
Not open for further replies.
Advertisement
  1. Jadan

    Jadan Thread Starter

    Joined:
    May 10, 2004
    Messages:
    123
    hello,

    on my Samsung Laptop, using Windows 7 Home Premium 64 bit.

    The location for the network is now stuck in Public with no option to change it back to Home.
    Internet works ok, but the icon of the network says Not connected.

    Any way to set this back to Home?

    Have tried the Microsoft Fix-It solution to no avail.

    Thank you

    Jadan
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    79,594
    First Name:
    Terry
    If it's a wireless connection try deleting the wireless profile and then reconnect.

    What actual problem are you experiencing?
     
  3. Jadan

    Jadan Thread Starter

    Joined:
    May 10, 2004
    Messages:
    123
    hi thanks for reply.

    It is a wireless network. I have already tried deleting the profile and reconnecting.
    The problem is that the icon on the bottom right taskbar shows the wireless connection as not connected and when I go into the Network & Sharing Centre , the map of my connection is not there and when I try to click on "Full Map" an error comes up telling me that Windows cannot show the map because my Network location is set to Public.
    There is no way I can change the Network location from Public to Home.

    Thank you

    Jadan
     
  4. CoolBurn

    CoolBurn

    Joined:
    Dec 5, 2013
    Messages:
    1,768
  5. Jadan

    Jadan Thread Starter

    Joined:
    May 10, 2004
    Messages:
    123
    Thanks for the link.

    Done the Fix-IT and doesn't resolve the issue.
     
  6. CoolBurn

    CoolBurn

    Joined:
    Dec 5, 2013
    Messages:
    1,768
    Little extreme but,
    Open Registry Editor, insure to make a backup of your current Registry.
    Next go to the following: HKLM\SOFTWARE\Microsoft\WindowNT\CurrentVersion\NetworkList\Profiles
    Now under Profiles in the left pane you may have a list of GUID numbers (the list can vary depending on how many profiles you have on the computer) start clicking on each one (GUID) until you see the appropriate network name in the right pane next to ProfileName. Once located in the right pane, double click on “Category” change the Value to 1 and click Ok. Close RegEdit and check the network location.
    Note the Value’s are as such in case you need to revert back
    Public: 0
    Private: 1
    Domain: 2

    If you get stuck or have questions during the above instructions please ask before attempting the change.
     
  7. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1147319

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice