New 1070 ti black screen prev. 1060

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Soulkge

Thread Starter
Joined
Oct 19, 2018
Messages
2
Ok guys I recently bought a 1070 ti I've done everything you can imagine it has power I've removed each individual sata reset motherboard u name it I took my1evga 1060 out without taking off drivers and put in my 1070 ti pny now i get a black screen and beeping I have a ryzen 7 1700 processor with no int. Graphics if I uninstall drivers on harddrive on another computer and put in 1070ti could that work or any other ideas please????
 
Last edited:
Joined
Mar 30, 2014
Messages
4,446
You do not need any video drivers loaded in order to view the CMOS/BIOS Setup. The video driver is for when Windows loads.
 

RT

Joined
Aug 20, 2000
Messages
12,233
Nvidia does recommend that you uninstall all previous drivers and hardware installations before installing your new card.

But it would be helpful to know your computer specs, and the exact timing/nature of the beeping.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top