1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

New build no monitor, mouse or keyboard

Discussion in 'Hardware' started by melissalynne7, Apr 4, 2008.

Thread Status:
Not open for further replies.
  1. melissalynne7

    melissalynne7 Thread Starter

    Joined:
    Nov 12, 2006
    Messages:
    8
    I just put everything together and when I start it up all fans are working but I don't get anything on the monitor and there are no lights on the mouse or keyboard. I have unplugged everything but the basics. I don't get any beeps but I don't think I have onboard sound. I have tried reseating everything and I don't know what the problem could be. Any ideas?

    My system:
    MOBO: Asus M2n-SLI Deluxe
    GRAPHICS: EVGA eGe-Force 9600 GT
    PROCESSOR: AMD Athlon 64 X2
    MEMORY: 2 2 GB A-Data DDR2 800
    HARD DRIVE: 120 GB Seagate SATA
     
  2. Jackiefrost9

    Jackiefrost9

    Joined:
    Jun 16, 2004
    Messages:
    3,765
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/700435

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice