1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

New MOBO, CPU, and RAM, no power! (Noob)

Discussion in 'Hardware' started by dmarasa, Jun 11, 2018.

Thread Status:
Not open for further replies.
  1. dmarasa

    dmarasa Thread Starter

    Joined:
    Jun 11, 2018
    Messages:
    1
    I have decided to switch my old MOBO, CPU and RAM out for some new ones. When I plugged the basics in my MOBO's LEDs light up and glow and when I hit the power button it flickers from blue to green, then resets to blue. It has passed the paper clip test and the fans turn on, but whenever I hit the power button normally and the lights change, the power doesn't come on. I am new to PC building to please be patient! My new MOBO is the asrock z370z, my CPU is the intel i7-8700K and my RAM is AEGIS ddr4
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1211458

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice