New Mouse won't work for Win98PLUS

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

iltat

Thread Starter
Joined
Jan 20, 2003
Messages
8
I purchased a new mouse for my computer last night, and I'm boggled by it so far. I have had a serial mouse previously, and my new mouse, a Belkin MiniScroller Optical Mouse has the ability apparently to work through a USB port or a PS/2 port. I first tried to install the mouse through the PS/2 port. Its cable is a USB cable, but it also included a USB to PS/2 adapter. I looked at the adapter, and three of the metal fingers that actually plug into the PS/2 port were bent. I bent these fingers back to their originally designed positions and then plugged the entire setup in. My questions are such:

1. When I failed at using the mouse through the PS/2 port (I get an error saying that "No mouse is detected. If you want, it is safe to plug in a serial mouse now, if you want to plug a mouse into the PS/2 port, you must turn the computer off." If you would like to recreate this error, just turn your pc off, unplug your mouse, and turn your pc on.), why would the computer not read it? (My guess is that the adapter is bad, but I want to see if it's my pc before running to get a new one.)

So I then removed the connector and plugger the device in through my USB port. The computer immediately recognized the device and installed everything as it should have. Unfortunately, the device still does not work. I did a search for the best driver for the device, and the search returned with the statement that the best driver had been found and it was already installed on my computer. This brought me to my next question.

2. Why the heck won't the stupid thing work????

(Sorry, I've been jacking with this for about 4 hours now, and my frustration is beginning to show.)

Thanks for any help you can provide. If I don't get any responses by Monday, I'm gonna throw it in the lake...okay, probly not...I'll probably just return it to get a new adapter so that I can get frustrated with that one too. Thanks again.

Billy
 

~Candy~

Retired Administrator
Joined
Jan 27, 2001
Messages
103,706
Is this your first USB device? Do you have others that have worked before? In the bios setup, is USB support set to ENABLED?
 

iltat

Thread Starter
Joined
Jan 20, 2003
Messages
8
This is the fourth USB enabled device that I have bought. So far, two of the other three have worked in this USB port while the other one has always stayed in the other USB port on my pc. Thanks though.
 
Joined
Mar 20, 2000
Messages
574
I agree, the adapter is broken, possibly it killed the mouse by plugging it in

exchange it for a new one
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top