1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

New PC Build - No Display on Monitor

Discussion in 'Hardware' started by freeze646, May 16, 2019.

Advertisement
  1. freeze646

    freeze646 Thread Starter

    Joined:
    May 16, 2019
    Messages:
    2
    I just built a new PC
    Computer parts:

    Motherboard: Gigabyte b450m ds3h

    CPU: Ryzen 2600x

    Graphics card: rtx 2070

    DRAM: Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3000MHz C15

    Case: Cooler Master k350.

    It turns on, everything lights up and fans turn on too but no images are being displayed to my monitor.

    If anyone could help I would appreciate it
     
  2. cwwozniak

    cwwozniak Trusted Advisor Spam Fighter

    Joined:
    Nov 28, 2005
    Messages:
    61,761
    First Name:
    Chuck
  3. flavallee

    flavallee Trusted Advisor

    Joined:
    May 12, 2002
    Messages:
    79,121
    First Name:
    Frank
    Gigabyte GA-B450M-DS3H (support site)
    GeForce RTX 2070 (support site)

    That motherboard has integrated DVI-D and HDMI video ports.
    That graphics card has DVI-DL and HDMI and DisplayPort and USB Type-C video ports.
    Which type video connection are you using between the computer and monitor?

    cpu.JPG gpu.JPG

    That processor and graphics use a combined total of 270W of power, and the graphics card requires a minimum of a 550W power supply.
    What's the brand name and complete model number and wattage of the power supply unit?

    ----------------------------------------------------------------
     
  4. freeze646

    freeze646 Thread Starter

    Joined:
    May 16, 2019
    Messages:
    2
    im pretty sure its a 750w can remember the brand unfortunatley. ive tried display port connection and hdmi but still no luck :(
     
  5. crjdriver

    crjdriver Moderator

    Joined:
    Jan 2, 2001
    Messages:
    38,574
    The only port you are going to get video out is from the video card. Just because you see video ports on the motherboard, does not mean it has video. Those ports are there for the APU line of processors. The ryzen 2600 does not have onchip video so connecting a cable to the motherboard port does nothing.

    As pointed out above, if you read and follow ALL of the steps of the guide, you will find the cause of your problem.

    Common errors for new builders;
    1 8/12pin aux pw connector not plugged in
    2 Motherboard shorting to case due to incorrect placement of standoffs
    3 Ram, video card, etc not fully seated
    4 Heatsink fan not installed correctly. This is more an intel problem than an amd problem since the amd type coolers are pretty much idiot proof
     
  6. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...

Short URL to this thread: https://techguy.org/1227247

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice