1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

New RX580, PC wont turn on. Help me please, first build!

Discussion in 'Hardware' started by elucase, Jul 10, 2019.

Thread Status:
Not open for further replies.
  1. elucase

    elucase Thread Starter

    Joined:
    Jul 10, 2019
    Messages:
    2
    I just bought a new sapphire rx 580 pulse 8gb for my pc. I turned it off, unplugged it, removed the rx 460, and put the rx 580 in, and plugged its power cord into the psu. When I attempted to turn on the computer after plugging it in, the pc would not turn on. The only thing that did anything, was that the cpu problem light on the motherboard turned on for a few seconds. I started troubleshooting. I tried unplugging the gpus power cord, but leaving it in the x16 slot. I then tried to turn it on, everything turned on, and the cpu problem light did not turn on. but the vga problem light did turn on (to be expected due to the lack of power). and nothing came on the monitor (also to be expected). I tried putting back in the rx 460, and my system ran just fine. I am at a loss. Any suggestions will be happily accepted. Thank you!

    My computer's specs
    Processor: Ryzen 5 2600
    Old GPU that works fine: Gigabyte RX 460 4 GB
    New GPU that is problematic: Sapphire RX 580 8 GB PULSE
    Motherboard: Gigabyte Aorus X470 Ultra gaming
    Wireless card: Asus
    HDD: WD Blue 1 TB 7200 Rpm
    SSD: WD Blue 500 GB
    Case: Cooler Master HAF 932
    PSU: OCZ ModX 700w
    OS: Windows 10
    If you need to know anything else, just ask.
     
  2. lunarlander

    lunarlander

    Joined:
    Sep 21, 2007
    Messages:
    11,574
    So plug in the new GPU and it's power and try again. Maybe you didn't firmly plug it in the first time.
     
  3. elucase

    elucase Thread Starter

    Joined:
    Jul 10, 2019
    Messages:
    2
    I tried multiple times. I made sure that it was seated well in the x16. Just returned it to amazon. I am getting a gigabyte rx 580
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/1229803

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice