1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

nic acquires ip in the same range as the other nic ip when ics is enabled

Discussion in 'Networking' started by dvktc, Oct 2, 2008.

Thread Status:
Not open for further replies.
  1. dvktc

    dvktc Thread Starter

    Joined:
    Oct 1, 2008
    Messages:
    9
    hi all.

    I have ICS enabled on a host computer running windows XP. the external d-link NIC is connected to a cable to the internet throught PPPoE (user name and password). when connected the external nic aquires an ip 172.0.4.156 in normal functioning.

    The internal RTL 8139d NIC is set as the internal network. with ip set manually to 192.168.0.1.

    and the internal NIC is connected to Dir-300 router configured to obtain connection dynamically from ICS dhcp. afterwards my laptop running vista gains access to the internet through the wireless router -> through ICS host xp computer. ( I have done this because I couldnt connect my router to the internet through pppoe although the router has pppoe capability).

    now the problem is after using internet for a while and when I restart my xp host computer. the external nic becomes problematic. acquiring an ip of 192.168.0.128, in the same range as the internal network ip. the amazing thing is when I connect to pppoe it connects normal. and internet connection is valid on the same computer.

    the problem is my laptop losses access to the internet while remain connected locally. to restore the connection you need to restart the wireless connection. then you gain access for a while then you lose it. and so forth.

    I have tried uninstalling/reinstalling the drivers on the xp host computer but the external kept aquring the same ip address.I have tried to disable ics and enable. deleted the pppoe connection and reconfigured it along with ics.

    any one has an answer please. or an idea on how to make the router connect to the internet through pppoe. this would solve all the problems.​
     
  2. TerryNet

    TerryNet Moderator

    Joined:
    Mar 23, 2005
    Messages:
    78,264
    First Name:
    Terry
    Configure the router's WAN (Internet) section with the appropriate PPPoE, user name, password, etc., information and use the clone MAC Address function to set the WAN MAC to the same as your computer's NIC that now connects (just in case your ISP tracks this).

    Unplug modem and router and shut down computers. Connect modem to router's WAN port and computer(s) to router LAN port(s).

    Plug in modem, plug in router, boot computer(s) in this order.

    If no internet access please show ...

    Start, Run, CMD, OK to open a command prompt:
    (For Vista type CMD in the Search box after Start)

    Type the following command:

    IPCONFIG /ALL

    [Note that there is no space between the slash and ALL.]

    Right click in the command window and choose Select All, then hit Enter.
    Paste the results in a message here.

    If necessary use a text file and removable media to copy the results to a computer with internet access.
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/755348

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice