nic acquires ip in the same range as the other nic ip when ics is enabled

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

dvktc

Thread Starter
Joined
Oct 1, 2008
Messages
9
hi all.

I have ICS enabled on a host computer running windows XP. the external d-link NIC is connected to a cable to the internet throught PPPoE (user name and password). when connected the external nic aquires an ip 172.0.4.156 in normal functioning.

The internal RTL 8139d NIC is set as the internal network. with ip set manually to 192.168.0.1.

and the internal NIC is connected to Dir-300 router configured to obtain connection dynamically from ICS dhcp. afterwards my laptop running vista gains access to the internet through the wireless router -> through ICS host xp computer. ( I have done this because I couldnt connect my router to the internet through pppoe although the router has pppoe capability).

now the problem is after using internet for a while and when I restart my xp host computer. the external nic becomes problematic. acquiring an ip of 192.168.0.128, in the same range as the internal network ip. the amazing thing is when I connect to pppoe it connects normal. and internet connection is valid on the same computer.

the problem is my laptop losses access to the internet while remain connected locally. to restore the connection you need to restart the wireless connection. then you gain access for a while then you lose it. and so forth.

I have tried uninstalling/reinstalling the drivers on the xp host computer but the external kept aquring the same ip address.I have tried to disable ics and enable. deleted the pppoe connection and reconfigured it along with ics.

any one has an answer please. or an idea on how to make the router connect to the internet through pppoe. this would solve all the problems.​
 

TerryNet

Terry
Moderator
Joined
Mar 23, 2005
Messages
80,961
Configure the router's WAN (Internet) section with the appropriate PPPoE, user name, password, etc., information and use the clone MAC Address function to set the WAN MAC to the same as your computer's NIC that now connects (just in case your ISP tracks this).

Unplug modem and router and shut down computers. Connect modem to router's WAN port and computer(s) to router LAN port(s).

Plug in modem, plug in router, boot computer(s) in this order.

If no internet access please show ...

Start, Run, CMD, OK to open a command prompt:
(For Vista type CMD in the Search box after Start)

Type the following command:

IPCONFIG /ALL

[Note that there is no space between the slash and ALL.]

Right click in the command window and choose Select All, then hit Enter.
Paste the results in a message here.

If necessary use a text file and removable media to copy the results to a computer with internet access.
 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Staff online

Top