No bootable device error (Acer Predator, Win 10)

quantizedself

Thread Starter
Joined
Oct 27, 2020
Messages
2
Last week I got a no bootable device error after my computer completely froze up forcing me to restart. This had happened a handful of times in recent months, but it always booted up after a couple restarts. This time it didn't. Here's what I've done:



  • Reset the battery, and re-seated the SSD
  • Checked bios for correct date, and switched from UEFI to Legacy then back again

    Used Windows installation media to:
  • diagnose a problem (none found)
  • Recover to a restore point. One was found and the process was successful. Still no boot.
  • restore to a previous version and load from an image, but neither were found
  • Fresh install of Windows. The media found my SSD, identified the partitions, and successfully installed. I did this twice, so now I have three versions of windows on the SSD. Still no boot.
  • Installed Windows on my HDD (normally for storage). Installation was successful. Still no boot.

    Then I tried:
  • Taking out the SSD and only booting from HDD. No boot error. Tried installing windows again on it, but got an error saying it could not find or create a partition (even though it had already successfully installed, i thought)
  • Taking out the HDD and only booting with the SSD.

    Then I used the command prompt (following instructions on a website):
  • to check and fix the MBR
  • rebuild the MBR
  • perform a scandisk to identify and fix errors. This process took hours, and at the end got an error that said it could not complete for fix the issues

  • Finally I made a bootable media with the AOMEI Partition Assistant program on it, and followed the instructions to rebuild the MBR from scratch. This took the program several hours to do. However, still no bootable device error.
I am completely out of ideas and at a loss. This is infinitely frustrating. Is there anything else I could do? What could the issue be? I need to avoid reformatting the SSD except for absolute last resort. This is my work/school computer as well as my gaming computer, and I haven't backed up my data. Any advice or support is greatly appreciated.
 
Joined
Sep 21, 2007
Messages
12,565
Could be the SATA component is malfunctioning. If this is a desktop, you could swap the motherboard and test.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Top