1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

no response when clicking mouse-sometimes

Discussion in 'Hardware' started by geeknana, Apr 5, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. geeknana

    geeknana Thread Starter

    Joined:
    Jul 20, 2006
    Messages:
    11
    my open windows will not respond to mouse clicks-whole pc is not locking up. i can use ctrl-alt-delete to unstick the window but it still takes lots of clicks on the task manager window to shut down the program & start over. This behavior does NOT take place when I am on the internet. I use Firefox.

    I have a HP laptop running XP. It has performed fabulous for 2 yrs, until this. I have run numerous times - Spyware Dr, Lavasoft Adaware, AVG Antivirus. AVG Rookkit detector, PC Optimize & Registry Mechanic. I have updated the touchpad driver, installed all Microsoft updates & HP updates. This behavior happens no matter which HD I am accessing - I have 2 100 GB HD in the PC & an external 500 GB HD.

    Please help. I desperately do not want to wipe my whole OS & start over if at all possible. Thanks in advance for any input i get on this problem. geekynana in CA
     
  2. Megabite

    Megabite

    Joined:
    Apr 5, 2008
    Messages:
    11,761
    Does the same happen when you are in Safemode?

    Restart the PC immediately start tapping F8 and a black screen with white lettering will come up...choose Safemode and test

    to get back to Normal mode just restart the PC
     
  3. geeknana

    geeknana Thread Starter

    Joined:
    Jul 20, 2006
    Messages:
    11
    yes, it also happens in safe mode. I tried running AVG antivirus & spyware dr in safe mode in case malware could not be removed in normal mode. did not help the mouse problem.

    this morning, problem was still here altho you can see i have no problem with the mouse working in my browser once i finally got it to open. that took alot of clicks & ctrl-alt-del pressing to get the icon to respond. i can also move my cursor with no problem, but when i click nothing happens.

    thanks again, geekynana
     
  4. Megabite

    Megabite

    Joined:
    Apr 5, 2008
    Messages:
    11,761
    Have you tried another mouse to see if that is the problem.
     
  5. geeknana

    geeknana Thread Starter

    Joined:
    Jul 20, 2006
    Messages:
    11
    i have not tried another mouse because this happens when i use the touchpad on the laptop too. if the touchpad worked ok i would have assumed it was the external mouse. i have tried using just the touchpad with the external mouse disconnected - same problem.

    any new idea for me to try? this is so perplexing. thanks - geekynana
     
  6. geeknana

    geeknana Thread Starter

    Joined:
    Jul 20, 2006
    Messages:
    11
    It looks like I am back in business! I finally dawned on me to try a system restore from a week ago & that seems too have fixed the problem. Hopefully it stays fixed. Good computing to all.
     
  7. Megabite

    Megabite

    Joined:
    Apr 5, 2008
    Messages:
    11,761
    Good old restore many people forget about it...glad its working again
     
  8. Sponsor

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/700512

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice