1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

No Sound after ComboFix

Discussion in 'Virus & Other Malware Removal' started by snooten, Apr 6, 2008.

Thread Status:
Not open for further replies.
  1. snooten

    snooten Thread Starter

    Apr 6, 2008
    I don't know if I should be putting this in the Multimedia or Malware forum, but here goes.

    I downloaded ComboFix this morning. No no sound, system or otherwise, despite my system saying all systems should be go. No device loaded. And no, I didn't do the System Recovery thing, which I'll do next time.

    I've been researching this all day and have found solutions, none of which are working for me. The last likely culprit for this problem is that ComboFix quarantines a driver file called msacm32.drv. That's not my case, either. That driver is intact on my system as is the .dll file.

    I looked for other potential drivers or sound-like files in the combofix log to no avail. Unfortunately, the log is no longer available, but I printed it out.

    Any help would be appreciated.
  2. snooten

    snooten Thread Starter

    Apr 6, 2008
    I saved this solution I found as my last resort, but it worked.
    I have had this problem before, all your drivers seem to be correctly installed but you get the "No audio device" message when entering sound properties. The problem is your Plug and Play Device Enumerator has been uninstalled (usually due to a virus).

    Follow these steps to re-install it:

    copy machine.inf from c:\windows\inf to a temp dir on your desktop
    delete line 20 which has the text: ExcludeFromSelect=*

    copy the following files to the same temp directory on your desktop:
    swenum.sys from c:windows\system32\drivers
    streamci.dll from c:\windows\system32

    .................................................. ...............................
    Note: If you cannot see the above files...

    go to TOOLS (in explorer)
    click tab VIEW
    look at advanced settings and click radio button for: Show Hidden Files and Folders
    and UNcheck the box for: Hide Protected Operating System Files
    .................................................. ...............................

    Go to add new hardware in Control Panel, allow it to seach, when it finds no new hardware choose "Yes I have already installed the hardware" and click next.

    It will then show you a list of devices, go to he bottom and select "Add a new hardware device" hit next.

    From the next dialogue select "Install the hardware manually from a list"

    Hit next on "show all devices"

    Click "Have Disk" and select the inf file fom your temp directory.

    From the list on the right select the plug and play software enumerator

    then it should re-install successfully.

    Reboot and you should have sound.

    I'd recommend running a virus scan just incase the original virus is still around too.

    Thanks so much.
  3. snooten

    snooten Thread Starter

    Apr 6, 2008
    When I started researching this problem, the above was one of the first fixes I found, but it was so scary I saved it for the last resort. I didn't really want to mess with the machine.inf file.

    I had no symptoms other than loss of all sound except for a lame system beep. When I did a boot log, drivers stopped loading with... Did not load driver ACPI Uniprocessor PC... and then went on for another 475 pages of trying. Loading and reloading and not loading.

    Spent a few hours researching ACPI and found the dll dependencies, ad nauseum. Best advice I found was..."I haven't checked out the specifics to the files mentioned in the error
    codes, but it sounds like the problem is related to a sound driver or something."

    The Device Manager had no flags. When I went to System Service...all audio services were dandy and on, plug and play was dandy and on. I reloaded my chipset drivers and my audio drivers. I downloaded every XP update possible. I downloaded a drivelist program. I went through every suspect event in the Event Viewer. I read a ton of Microsoft support junk.

    Everest showed a gray screen at Windows Audio. Nothing there. DirectX.exe told me there were no audio drivers. I had no hardware under Legacy Audio Drivers, but that was a red herring...of no consequence...still that way.

    Timidity cost me, I hate to say how many, hours wasted on avoiding the above fix. I followed it exactly and got an error that it didn't work before the system rebooted. I thought my system was toast. And voila, SOUND on reboot.

    Since I had uploaded service packs...was a little worried about where the machine.inf file was, but I used the Windows directory as instructed.

    Do this one first and get it done. If you create a system restore point you can do this without worry.

    btw, I checked everything in the combofix log which I was able to reconstruct and there was no file listed that would point to this problem. As a matter of fact, I was able to restore my system to the moment before I ran ComboFix and no sound.

    I hope this helps somebody.
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Similar Threads - Sound ComboFix
  1. goldfish87
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/701011

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice