No sound from optical out on Chaintech AV-710

Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Freaktown

Thread Starter
Joined
Jan 25, 2007
Messages
3
I just installed a Chaintech AV-710 sound card in my living room HTPC so that I can use it's optical connection with my home theater receiver. It is a KOSS KS3102. I have everything hooked up properly, but I cannot get any sound when I use the optical cable. It works fine with a regular RCA cable. I want to use the optical so I will get Dolby 5.1 when watching DVDs on the computer. I made sure that the receiver was set on Optical input. The drivers I am using are from www.viaarena.com since Chaintech's drivers link was broken and everybody seems to recommend the viaarena drivers. The engine on the AV-710 is Envy24. Windows XP SP2. Any ideas? Thank you in advance.
 

MysticEyes

Banned
Joined
Mar 30, 2002
Messages
4,825
Other Thoughts: I had to jump through some hoops to make this thing work with XP and MCE 2005. The card installed fine, but it had difficulty switching between 48Khz (DD or DTS) and 44Khz (CD) sources over SPDIF. To fix it do the following: From the Envy24 Audio deck utility select the 5.1 channel setting, disable SPDIF and select "AUTO" detect. After you selected "AUTO" re-enable SPDIF. The order is important or you will get locked into one format or the other even though it looks like auto is selected. Once this was solved it works like a champ. Excellent sound quality compared to onboard audio.

 

Freaktown

Thread Starter
Joined
Jan 25, 2007
Messages
3
Thanks for the reply. I will try that and post what happens.


MysticEyes said:
Other Thoughts: I had to jump through some hoops to make this thing work with XP and MCE 2005. The card installed fine, but it had difficulty switching between 48Khz (DD or DTS) and 44Khz (CD) sources over SPDIF. To fix it do the following: From the Envy24 Audio deck utility select the 5.1 channel setting, disable SPDIF and select "AUTO" detect. After you selected "AUTO" re-enable SPDIF. The order is important or you will get locked into one format or the other even though it looks like auto is selected. Once this was solved it works like a champ. Excellent sound quality compared to onboard audio.

 

Freaktown

Thread Starter
Joined
Jan 25, 2007
Messages
3
I tried your suggestion. No go. I can't get the surround speakers or the LFE channel to work. Am I supposed to use Auto, AC3, or PCM? Any other suggestions? Thanks.


MysticEyes said:
Other Thoughts: I had to jump through some hoops to make this thing work with XP and MCE 2005. The card installed fine, but it had difficulty switching between 48Khz (DD or DTS) and 44Khz (CD) sources over SPDIF. To fix it do the following: From the Envy24 Audio deck utility select the 5.1 channel setting, disable SPDIF and select "AUTO" detect. After you selected "AUTO" re-enable SPDIF. The order is important or you will get locked into one format or the other even though it looks like auto is selected. Once this was solved it works like a champ. Excellent sound quality compared to onboard audio.

 
Status
This thread has been Locked and is not open to further replies. Please start a New Thread if you're having a similar issue. View our Welcome Guide to learn how to use this site.

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 807,865 other people just like you!

Latest posts

Members online

Top