1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

No sound in some games

Discussion in 'Windows Vista' started by cmeeson, Feb 6, 2007.

Thread Status:
Not open for further replies.
  1. cmeeson

    cmeeson Thread Starter

    Joined:
    Feb 6, 2007
    Messages:
    2
    First of all here are my computer specs

    AMD Athlon 64 processor
    1 gig of RAM
    Radeon x1600 video card
    Asus K8V-X SE mobo
    SoundMAX Integrated Digital Audio
    running Windows Vista Ultimate

    I wasn't sure which forum to post this in, the Vista forum or the games forum, so sorry for the double post.

    So after installing Vista and getting all my drivers set up I figured I'd try out some games to see how they played. Well, most games are working fine, but neither Half Life 2 or Counterstrike Source have sound, and I really have no idea why. Sound works outside of those games, and it works fine for other games, so I don't know what the problem is. I also haven't been able to find anyone else who is having this problem, so any insight would really be appreciated.

    Windows tells me all sound drivers are up to date, but when I check the ASUS site for audio drivers for my mobo, it doesn't list any drivers for Vista yet. Should I just wait a bit to see if they release a new driver, should I go out and buy a new sound card, or can my problem be solved another way?

    Thanks for the help!

    edit: I accidentally discovered that if I have audio running (winamp) when I open CS or HL2, they'll also play their audio. It's the same with Youtube videos. I dunno, the audio seems really finicky. Sometimes it'll play and other times it won't. Still, any clue what could be wrong?
     
  2. oliver.d

    oliver.d

    Joined:
    Feb 6, 2007
    Messages:
    29
    Have you tried running the cames in compatability mode for XP SP2? Right click the application .exe in the programs folder, and go into the compatability tab. Also try running as administrator if XP compatability doesnt work. If you are still having problems, you will have to wait for patches. Vista isn't the number one gaming platform.. yet.
     
  3. -mx-

    -mx-

    Joined:
    Mar 2, 2007
    Messages:
    1
    Hi cmeeson,

    had the same problem with similar config :
    ASUS P4P800-X motherboard
    Soundmax Integrated Digital Audio
    Windows Vista Ultimate.

    When starting HL2 and CS source = No sound.

    Did the following :
    Went to Asus Website and downloaded the Soundmax driver for Win XP.
    extract the Zip file and right click on "setup.exe". under compatibility, tick the Win XP w/SP2 field
    use also "run as administrator"
    It told me that he had to uninstall existing driver and after completed installation, restart and I now have sound in HL2 and CS source as before.

    give it a try

    Regards
    -mx-
     
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/541645

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice