1. Computer problem? Tech Support Guy is completely free -- paid for by advertisers and donations. Click here to join today! If you're new to Tech Support Guy, we highly recommend that you visit our Guide for New Members.

No sound; no audio device detected. Yikes!!

Discussion in 'Hardware' started by Halostatue, Mar 31, 2008.

Thread Status:
Not open for further replies.
Advertisement
  1. Halostatue

    Halostatue Thread Starter

    Joined:
    Mar 31, 2008
    Messages:
    2
    Okay…I give up. I’ve got to ask for some help.

    I recently re-installed XP Media Center on my Dell Dimension E310. Now, whenever I re-start I have no sound. And when I go the Control Panel, I get the “No Audio Device” with all of the selections grayed-out. And I mean all of them: The Volume section, the Sounds section, the Audio section…all of them. When I troubleshoot the hardware is says the device is working properly.

    I’ve searched this site (and lots of others!) and have noticed this same problem reported by many others. And I’m pretty sure I’ve tried all the solutions presented. Either I’m a dope (real possibility there), or something’s wack.

    I’ve reloaded the correct motherboard drivers, the video drivers and the sound card (SigmaTel, onboard) drivers, from both the Dell site and from the individual manufacturer sites. I’ve un-installed and installed again. Everything. In the correct order. I’ve re-installed XP Media Center and even re-installed just plain ole XP Pro, trying to figger this out. I’ve gone through the PNP Device Enumerator “solution”.

    I’ve gone to the “services” and made sure the Windows Audio is set to “Automatic” and is started. I’ve stopped it, rebooted and re-started it and re-booted it.

    I’ve read and read and read and then tried and tried and tried potential solutions, but it keeps being a bad, bad, misbehaving system. I’ve used both Belarc and Everest Home Edition. When the sound’s not working, neither one even see my sound card. When it’s working, they see it. These programs are how I know it’s a Sigmatel card and how I know my motherboard, for the correct drivers.

    Periodically, the sound will come on and everything will work perfectly. The machine is fast, the sound is great and nothing seems wrong at all. I will set a restore point at that time, place and configuration. When the sound “fails” again, I go back to the restore point and…no sound.

    I can log off and re-logon and it’ll be fine. BUT…if I re-start, it comes back up with the no sound, no device thing I described above.

    When I look in the Device Manager, the only yellow question mark I get is the “PCI Simple Communications Controller” one. And when I try to “update” the driver, the system won’t find one. I’ve tried to search the web for one, but nojoy up to now.

    Two more pieces of info: When the sound’s not working, many times the PC will just seem to lock up. The cursor “hourglass” will just spin. Like for 5 or 10 minutes (sometimes until I just power the thing off). And periodically, when the PC catches up, the sound will work fine. It’s as if the computer’s trying to bring the drivers up, is having a hard time with it, and once it gets it all straightened out everything works great. ‘Til I re-start.

    The second thing is that when I look in the device manager, I have TWO instances of the Plug and Play Device Enumerator. And they’re the same. Maybe they’re colliding. I can’t find out how to uninstall one of them. “Uninstall” isn’t an option presented.

    I’m at my wit’s end. I’m not at that particular computer right now (on the road for work), but I’ll try to answer any questions you have to try to help diagnose/solve this deal. I do have logmein working, so I can probably find out whatever’s necessary from where I am.

    As a side note, I’ve tried drinking more, but that just makes it fuzzier and doesn’t solve the problem <grin>. Maybe I’m not drinking the right stuff…Any suggestions along this line may not solve anything, except help kill the pain…

    Any help would be appreciated.

    Halostatue
     
  2. Halostatue

    Halostatue Thread Starter

    Joined:
    Mar 31, 2008
    Messages:
    2
    So maybe another question might be:

    How does one uninstall an instance of "Plug and Play Device Enumerator"?

    Halostatue
     
  3. snooten

    snooten

    Joined:
    Apr 6, 2008
    Messages:
    5
    I got this from this forum, I think...and I'll just copy and paste what I found...This works! And to whomever, THANKS.
    ==============
    I have had this problem before, all your drivers seem to be correctly installed but you get the "No audio device" message when entering sound properties. The problem is your Plug and Play Device Enumerator has been uninstalled (usually due to a virus).

    Follow these steps to re-install it:


    copy machine.inf from c:\windows\inf to a temp dir on your desktop
    delete line 20 which has the text: ExcludeFromSelect=*

    copy the following files to the same temp directory on your desktop:
    swenum.sys from c:windows\system32\drivers
    streamci.dll from c:\windows\system32

    .................................................. ...............................
    Note: If you cannot see the above files...

    go to TOOLS (in explorer)
    select FOLDER OPTIONS
    click tab VIEW
    look at advanced settings and click radio button for: Show Hidden Files and Folders
    and UNcheck the box for: Hide Protected Operating System Files
    .................................................. ...............................

    Go to add new hardware in Control Panel, allow it to seach, when it finds no new hardware choose "Yes I have already installed the hardware" and click next.

    It will then show you a list of devices, go to he bottom and select "Add a new hardware device" hit next.

    From the next dialogue select "Install the hardware manually from a list"

    Hit next on "show all devices"

    Click "Have Disk" and select the inf file fom your temp directory.

    From the list on the right select the plug and play software enumerator

    then it should re-install successfully.

    Reboot and you should have sound.

    I'd recommend running a virus scan just incase the original virus is still around too.

    ======================

    I got some errors on the install, but when I restarted...sound!

    Good Luck
     
  4. snooten

    snooten

    Joined:
    Apr 6, 2008
    Messages:
    5
As Seen On
As Seen On...

Welcome to Tech Support Guy!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.

Join over 733,556 other people just like you!

Loading...
Thread Status:
Not open for further replies.

Short URL to this thread: https://techguy.org/699054

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice